summaryrefslogtreecommitdiff
path: root/app-dicts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-23 00:11:31 +0100
commitbff543bb632933380da922cbfc07c67157d72d42 (patch)
treedf2e5eebc3dbd8e29153ab3a869b3be8d9be9f19 /app-dicts
parent491d0101c89d81dec507f28215b3cb094800d600 (diff)
gentoo auto-resync : 23:06:2024 - 00:11:30
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/Manifest.gzbin31658 -> 31654 bytes
-rw-r--r--app-dicts/verbiste/Manifest2
-rw-r--r--app-dicts/verbiste/verbiste-0.1.48.ebuild63
-rw-r--r--app-dicts/ydpdict/Manifest2
-rw-r--r--app-dicts/ydpdict/ydpdict-1.0.5.ebuild57
5 files changed, 124 insertions, 0 deletions
diff --git a/app-dicts/Manifest.gz b/app-dicts/Manifest.gz
index 45b804befcf7..56620a977c0f 100644
--- a/app-dicts/Manifest.gz
+++ b/app-dicts/Manifest.gz
Binary files differ
diff --git a/app-dicts/verbiste/Manifest b/app-dicts/verbiste/Manifest
index 83c495faf75d..d8a14c666e80 100644
--- a/app-dicts/verbiste/Manifest
+++ b/app-dicts/verbiste/Manifest
@@ -1,3 +1,5 @@
DIST verbiste-0.1.47.tar.gz 781085 BLAKE2B 39f92bffc2165b49a2cd66ced4337aa4eb4253a1d767f0c26cea0bc10e965a5547158ab0de796b76016fd46bd220b305a14c9be42b76f5a25f0fde85e4ff1b97 SHA512 cc06d3e4a09b9edf2fe3996f527ae05fa50af909cc5ea6ed830d1b4f5706cf9b29028160cff842a211148e13d736f7e2cb74f10b3c5fd84d93a1038e05a26cbf
+DIST verbiste-0.1.48.tar.gz 807115 BLAKE2B 666df78baf30ae4fba19e86dc2b812ea6ea6711829d46e6c1e5474f3b500576c992a3338abdbe6c347d154d1f37b696ef59e1e60a8ab79c2ef5b9584d026ac2a SHA512 4d0ac1a1116b51196b1ba72cceed507c56551ed97d2de07dfbf1f6eb48769a7c3c1ee676aa3a2d3f9e3cb512df3808d9bb1da9c7166a820cc3379ff06f4f14f2
EBUILD verbiste-0.1.47.ebuild 1084 BLAKE2B 3b51aa81abf03300c16440b199eb79295ad6946c44e29ad163d67d1c9de7077e657e58af9646c2701cc7e78a48ebb4b03c548516117847e04831d25b71696646 SHA512 24dcc9e1963b8089c02a866d52d446b5d40aa00582ecf1bd4fbcf25f3e708cb675a9fa0a4214830cc1a76aafc18a089efa0088a7c7ee1c363f63cf1d693007c1
+EBUILD verbiste-0.1.48.ebuild 1124 BLAKE2B bcbfac4aa60c0f05cd5b5c108ad13ab1b339bf72c5e237a43807812df7929c60744525e06e8ad5fe95d639efc31d9208f98da3879ce5097b1b499a0adc73fb5c SHA512 997de25f27b786fe56fdf7bf031a1bc6d7407a7c0487267fd281d1d386c243cb513d62d2df5c5869fa6dbc7fa682f2ab08530d9eea9db2f343ba61119aaccb18
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-dicts/verbiste/verbiste-0.1.48.ebuild b/app-dicts/verbiste/verbiste-0.1.48.ebuild
new file mode 100644
index 000000000000..b5a0b66f3fe5
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.48.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --with-console-app
+ --without-gnome-app
+ --without-gnome-applet
+ $(use_with gtk gtk-app)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ domenu src/gnome/verbiste.desktop
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ fi
+}
diff --git a/app-dicts/ydpdict/Manifest b/app-dicts/ydpdict/Manifest
index 89bc01878856..38bf2a86791d 100644
--- a/app-dicts/ydpdict/Manifest
+++ b/app-dicts/ydpdict/Manifest
@@ -1,6 +1,8 @@
AUX ydpdict-1.0.3-clang16-build-fix.patch 246 BLAKE2B 0eac87877bf119dd0252e8b1a7a7ac78d5e1b07c7057785c2d41748885080f6863d583783760d8a73687d6aced0a02c59b8e7519389f52f4c1a1519f28037004 SHA512 cc1d029b13b7b892350174908af29fb6a761a14b77bf1b39273d64a0e1484ca67f74e30998e4376e1fe826d835871d06bde9376cd843fcb799a42574c554c489
AUX ydpdict-1.0.3-tinfo.patch 322 BLAKE2B bfde4da1cb49749e8023f7c8ce56dad45b9ee39e974eb59df41e40a4770debdc8f47f4ae03bba41739bdbfbde5ba90315f454e3fa8f5cf8cee668ffbb109e0d5 SHA512 70e0b4b528dabcf9889eaff2909e11a8481ece94ff50d90c7c53e1b5f655f3954bbf694446ee3cf4fa2ac21b1c329d627412337f17da2e8a0a1ba73a45304857
DIST ydpdict-1.0.3.tar.gz 185721 BLAKE2B 1db80dc20dd6d71c4b7fed2051bbfae1021fd1ea15ca1f993e8e095912fbcc8d599d8f480143d185fd11c6a1414d7f29ae67a9f5cffda624b434d198cddc5c68 SHA512 ca50c485f10aa4c4691a27a474a5ae814be3bb183b4927728f14de67af1e11a281e5272fc5777d6573e69dd00d3da2223b78d729132764338c92489f20eb17e8
+DIST ydpdict-1.0.5.tar.gz 191401 BLAKE2B 5b57e16d36fe744e435924546c55bb5d0e130a1e76ec743cb871ccf71bb53d5999a8ba5eb3cca0db8ae6d4f3680642d2d243f067a4bef653d375ccf9e203f460 SHA512 12fcee0612560ebea3942ce31ef6b4927bd033cd45e9dd6e677a8aefcf3a81feb267ad77953e3ed1a904428586e41df8dd8c732cdbe1e9a3220cc46c153030c1
EBUILD ydpdict-1.0.3-r1.ebuild 1128 BLAKE2B 123b72f70e9486fcff45df65503d9550616eb0354059b7c8ba035d78fd3ae76e53b2c1fe691e0e462d2feb8261a10e3946434fbe0805c37e0fbd874ec87e4122 SHA512 bc02d02d05550878549fbd1e795c5e4d7ba76058ad160f46aea5dba3b7b6b462e6dc6f6525b5da27a75e16ae9113a1d08b4f0dd05fb2ea72ba16e34b7fe66e46
EBUILD ydpdict-1.0.3-r2.ebuild 1179 BLAKE2B 5d1a0522b863faa6f48110e8d7b832ce6d2e763732053e9d8dbd691bc1cca1e9fb97bfd7d2bc2f6d5ba8fc1f34364529b6120716451e08b5a09a5487435424f9 SHA512 e4d31360db38b968743934233c3404f382485992ec6a7de7b6e9906b06493e2de72619970dd4fd435622dbd9f4c5811c8da424af09c8bee28b1735515731b2f3
+EBUILD ydpdict-1.0.5.ebuild 1113 BLAKE2B db75a30765bcfc1c60d53386d12a22c94b245ea3ae3cf18553ba5521355efbb97bf95cf586642e28a0ebc29a22748623440288ef996195cc7fd4cd7bfe8beb0a SHA512 784b70e1452d9a337ace3baf89f50cd481776524a5fa29b7bef469fd47777ba40336c62e25f1c0a5cae80044e5056f761a20bdf72eaed9aad0a414277d5fd86f
MISC metadata.xml 249 BLAKE2B 7da21f257854aaa71c2ffdb3f700dddf6b4c5aafd3fbb923100c263e210a647d7c0ddf48cfe2bcd9801a594d4fbf73df5ef095a3ca4c786cce6f95560e8964b8 SHA512 afa1ecf431f11a622e8fcabefbd0fb26086fab18df5a9b75064e42429e02cbaf00e729df4ec82f6e34c1a98bb58f25e20fd9fdce2cc072aa8d4b418b1730f153
diff --git a/app-dicts/ydpdict/ydpdict-1.0.5.ebuild b/app-dicts/ydpdict/ydpdict-1.0.5.ebuild
new file mode 100644
index 000000000000..c29a3178c033
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-1.0.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interface for the Collins Dictionary"
+HOMEPAGE="https://github.com/wojtekka/ydpdict"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="ao"
+
+RDEPEND="
+ app-dicts/libydpdict
+ sys-libs/ncurses:=[unicode(+)]
+ ao? ( media-libs/libao )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ao libao)
+}
+
+src_install() {
+ dodir "/etc"
+ default
+}
+
+pkg_postinst() {
+ echo
+ elog "Note that to use this program you'll need the original Collins Dictionary"
+ elog "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ elog "directory of the Windows version of the Collins dictionary. Once you obtain"
+ elog "the files, put them into /usr/share/ydpdict"
+ elog
+ elog "Some configuration options can be set in /etc/ydpdict.conf"
+ echo
+}