summaryrefslogtreecommitdiff
path: root/app-dicts/verbiste/verbiste-0.1.44.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/verbiste/verbiste-0.1.44.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/verbiste/verbiste-0.1.44.ebuild')
-rw-r--r--app-dicts/verbiste/verbiste-0.1.44.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-dicts/verbiste/verbiste-0.1.44.ebuild b/app-dicts/verbiste/verbiste-0.1.44.ebuild
new file mode 100644
index 000000000000..c9a1c7a067d7
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.44.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils gnome2-utils xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ insinto usr/share/applications
+ doins src/gnome/verbiste.desktop
+ fi
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}