summaryrefslogtreecommitdiff
path: root/app-dicts/verbiste/verbiste-0.1.41.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/verbiste/verbiste-0.1.41.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/verbiste/verbiste-0.1.41.ebuild')
-rw-r--r--app-dicts/verbiste/verbiste-0.1.41.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-dicts/verbiste/verbiste-0.1.41.ebuild b/app-dicts/verbiste/verbiste-0.1.41.ebuild
new file mode 100644
index 000000000000..bc9afe0a502c
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.41.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils gnome2-utils xdg-utils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://sarrazip.com/dev/verbiste.html"
+SRC_URI="http://sarrazip.com/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.4.0:2
+ gtk? ( >=x11-libs/gtk+-2.6:2 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --with-console-app \
+ --without-gnome-app \
+ --without-gnome-applet \
+ $(use_with gtk gtk-app)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ dodoc HACKING LISEZMOI
+ # file is only installed with USE=gnome
+ if use gtk; then
+ sed -e 's/Exec=.*/Exec=verbiste-gtk/' \
+ -i src/gnome/verbiste.desktop || die
+ insinto usr/share/applications
+ doins src/gnome/verbiste.desktop
+ fi
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk; then
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+ fi
+}