summaryrefslogtreecommitdiff
path: root/app-dicts/opendict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/opendict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/opendict')
-rw-r--r--app-dicts/opendict/Manifest3
-rw-r--r--app-dicts/opendict/metadata.xml11
-rw-r--r--app-dicts/opendict/opendict-0.6.7.ebuild89
3 files changed, 103 insertions, 0 deletions
diff --git a/app-dicts/opendict/Manifest b/app-dicts/opendict/Manifest
new file mode 100644
index 000000000000..868033875a08
--- /dev/null
+++ b/app-dicts/opendict/Manifest
@@ -0,0 +1,3 @@
+DIST opendict-0.6.7.tar.gz 169580 BLAKE2B 665fe181bf16d8e923470568b6685149075b6c5a9afe2deffe6ee4ff792b4e6a2c166f3ce4297f59fc57cd11efe299a93518c4fb5e929b13270d04f172a62146 SHA512 ef97ec84591bda4d8d4746fa4532de109cf03d89dfd5aa20e1775224c687b503759c020b2286e5cedd395ebce5db3b2a10495adc31fcc31dbd4fddfca6fee1f8
+EBUILD opendict-0.6.7.ebuild 2049 BLAKE2B 3cc51451ed9b8cf49a21141695ee6c8e33ff673d2e651e162e01a240667af0bf840f983f0ed47f5b8c95fd4ca5209fc17fb55fe2f8a7fce03cecfaf42aa02276 SHA512 30cd657a497536afa6c95de547ea48c50d3dd2e8e6af77b35d018fbc9522f43c6b5474f7967c829c07e635b38d99dc5501ac2f15d464cc201d557ed67bcea1ea
+MISC metadata.xml 339 BLAKE2B 3233d939c71c80bd1d803ef77bafb2d50022497ef3f580171d9bd37aa260c0b5d7e7d306a5bd98ab8a2bdd6b052048032887579c5064d7684b9aa43aa4a53ffd SHA512 49affe3fdde01f9c9726abbf3088e9332fd2aad7c47cb7591eee9d23dd18caf4877c2858e457b236bfec2318baa5e3cbf8184ae431825d6d28a01557a58daf98
diff --git a/app-dicts/opendict/metadata.xml b/app-dicts/opendict/metadata.xml
new file mode 100644
index 000000000000..e41fb4b553e3
--- /dev/null
+++ b/app-dicts/opendict/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wxwidgets@gentoo.org</email>
+ <name>Gentoo wxWidgets Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">opendict</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-dicts/opendict/opendict-0.6.7.ebuild b/app-dicts/opendict/opendict-0.6.7.ebuild
new file mode 100644
index 000000000000..99c27f354f2b
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.6.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program"
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opendict/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="If you want system-wide plugins, unzip them into
+${ROOT}usr/share/${PN}/dictionaries/plugins
+
+Some are available from http://opendict.sourceforge.net/?cid=3"
+
+src_prepare() {
+ sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
+ -i "${S}/lib/info.py"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # override gnome2_src_configure
+ default
+}
+
+src_compile() {
+ # evil makefile
+ :
+}
+
+src_install() {
+ # makefile is broken, do it manually
+
+ dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
+
+ # Needed by GUI
+ insinto /usr/share/${PN}
+ doins "${S}"/copying.html
+
+ insinto /usr/share/${PN}/pixmaps
+ doins "${S}"/pixmaps/*
+
+ DHOME="$(python_get_sitedir)/opendict"
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
+ exeinto "${DHOME}"
+ python_fix_shebang opendict.py
+ doexe opendict.py
+
+ dosym "${DHOME}/opendict.py" /usr/bin/opendict
+
+ domenu misc/${PN}.desktop
+
+ insinto /usr/share/icons/hicolor/24x24/apps/
+ newins "${S}/pixmaps/icon-24x24.png" opendict.png
+ insinto /usr/share/icons/hicolor/32x32/apps/
+ newins "${S}/pixmaps/icon-32x32.png" opendict.png
+ insinto /usr/share/icons/hicolor/48x48/apps/
+ newins "${S}/pixmaps/icon-48x48.png" opendict.png
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ newins "${S}/pixmaps/SVG/icon-rune.svg" opendict.svg
+
+ doman opendict.1
+ dodoc README.txt TODO.txt doc/Plugin-HOWTO.html
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}