summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild')
-rw-r--r--app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild b/app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild
new file mode 100644
index 000000000000..1ed79c8030ee
--- /dev/null
+++ b/app-dicts/myspell-ru/myspell-ru-20150711-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MYSPELL_DICT=( ru_RU.{dic,aff} )
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extensions"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.0"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/russian-dictionary-pack"
+SRC_URI="https://extensions.libreoffice.org/${EXT}/${DICT}/${MY_PV}/@@download/file/${MY_PN}-${MY_PV//./-}.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd"
+
+src_prepare() {
+ default
+ mv russian-aot.dic ru_RU.dic || die
+ mv russian-aot.aff ru_RU.aff || die
+}