summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild')
-rw-r--r--app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild b/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
new file mode 100644
index 000000000000..cb0e268cf3b0
--- /dev/null
+++ b/app-dicts/myspell-ru/myspell-ru-20150711-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MYSPELL_DICT=( russian-aot.{dic,aff} )
+
+MYSPELL_HYPH=( hyph_ru_RU.dic )
+
+MYSPELL_THES=( ru_th_aot.{dat,idx} )
+
+inherit myspell-r2
+
+EXT="extension-center"
+DICT="russian-dictionary-pack"
+MY_PN="dict_pack_ru-aot"
+MY_PV="0.4.0"
+
+DESCRIPTION="Russian spellcheck dictionary based on works of AOT group for myspell/hunspell"
+HOMEPAGE="http://extensions.libreoffice.org/extension-center/russian-dictionary-pack"
+SRC_URI="http://extensions.libreoffice.org/${EXT}/${DICT}/releases/${MY_PV}/${MY_PN}-0-4-0.oxt"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+
+src_install() {
+ myspell-r2_src_install
+ dosym ../hunspell/russian-aot.dic /usr/share/myspell/ru_RU.dic
+ dosym ../hunspell/russian-aot.aff /usr/share/myspell/ru_RU.aff
+}