summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild')
-rw-r--r--app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild b/app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild
new file mode 100644
index 000000000000..e0a531efe3e1
--- /dev/null
+++ b/app-dicts/myspell-nn/myspell-nn-2.0.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "nn_NO.aff"
+ "nn_NO.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nn_NO.dic"
+)
+
+MYSPELL_THES=(
+ "th_nn_NO_v2.dat"
+ "th_nn_NO_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Norwegian dictionaries for myspell/hunspell"
+HOMEPAGE="http://spell-norwegian.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/2357/no_NO-pack2-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ myspell-r2_src_unpack
+
+ for i in *.zip; do
+ unzip ${i} || die
+ done
+}