summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/myspell-nl/myspell-nl-2.10g.ebuild')
-rw-r--r--app-dicts/myspell-nl/myspell-nl-2.10g.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild b/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
new file mode 100644
index 000000000000..5b796993a00a
--- /dev/null
+++ b/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+MYSPELL_DICT=(
+ "nl_NL.aff"
+ "nl_NL.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nl_NL.dic"
+)
+
+MYSPELL_THES=(
+ "th_nl_NL_v2.dat"
+ "th_nl_NL_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Dutch dictionaries for myspell/hunspell"
+HOMEPAGE="http://opentaal.org/"
+# Thesarus is not versioned at all, I suppose we could bump it with each dict
+# release, or when people say that the download uri checksum changed.
+SRC_URI="
+ http://opentaal.org/bestanden/license_result/20-woordenlijst-v-${PV//./}-voor-openofficeorg-3?bid=20&agree=1 -> ${P}.oxt
+ http://data.opentaal.org/opentaalbank/thesaurus/download/thes_nl.oxt -> ${P}_thes.oxt
+"
+
+LICENSE="BSD-2 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ # thesarus has ugly name
+ mv th_nl_v2.dat th_nl_NL_v2.dat || die
+ mv th_nl_v2.idx th_nl_NL_v2.idx || die
+
+ # remove dutch translated license so it aint installed
+ rm -rf licentie* || die
+}