summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-es/myspell-es-2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/myspell-es/myspell-es-2.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/myspell-es/myspell-es-2.3.ebuild')
-rw-r--r--app-dicts/myspell-es/myspell-es-2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-dicts/myspell-es/myspell-es-2.3.ebuild b/app-dicts/myspell-es/myspell-es-2.3.ebuild
new file mode 100644
index 000000000000..93987efe68b5
--- /dev/null
+++ b/app-dicts/myspell-es/myspell-es-2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MUTATIONS=(
+ "es_ANY" "es_AR" "es_BO" "es_CL" "es_CO" "es_CR" "es_CU" "es_DO" "es_EC"
+ "es_ES" "es_GT" "es_HN" "es_MX" "es_NI" "es_PA" "es_PE" "es_PH" "es_PR"
+ "es_PY" "es_SV" "es_US" "es_UY" "es_VE"
+)
+
+MYSPELL_DICT=( )
+MYSPELL_HYPH=(
+ "hyph_es_ANY.dic"
+)
+MYSPELL_THES=(
+ "th_es_ES_v2.dat"
+ "th_es_ES_v2.idx"
+)
+
+SRC_URI=""
+for i in "${MUTATIONS[@]}"; do
+ MYSPELL_DICT+=(
+ "${i}.dic"
+ "${i}.aff"
+ )
+ SRC_URI+=" https://github.com/sbosio/rla-es/releases/download/v${PV}/${i}.oxt -> ${i}-${PV}.oxt"
+done
+unset i MUTATIONS
+
+inherit myspell-r2
+
+DESCRIPTION="Spanish dictionaries for myspell/hunspell"
+HOMEPAGE="https://github.com/sbosio/rla-es"
+LICENSE="GPL-3 LGPL-3 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ # remove license files
+ rm {GPL,LGPL,MPL}* || die
+ default
+}