summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-en/myspell-en-20170501.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/myspell-en/myspell-en-20170501.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/myspell-en/myspell-en-20170501.ebuild')
-rw-r--r--app-dicts/myspell-en/myspell-en-20170501.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/myspell-en-20170501.ebuild b/app-dicts/myspell-en/myspell-en-20170501.ebuild
new file mode 100644
index 000000000000..8a91e263b3ae
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20170501.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV:0:4}-${PV:4:2}.${PV:6:2}"
+
+MYSPELL_DICT=(
+ "en_AU.aff"
+ "en_AU.dic"
+ "en_CA.aff"
+ "en_CA.dic"
+ "en_GB.aff"
+ "en_GB.dic"
+ "en_US.aff"
+ "en_US.dic"
+ "en_ZA.aff"
+ "en_ZA.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_en_GB.dic"
+)
+
+MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/extensions/english-dictionaries/${MY_PV}/@@download/file/dict-en-${PV}.oxt"
+
+LICENSE="GPL-2 LGPL-2.1 Princeton myspell-en_CA-KevinAtkinson"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""