summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild')
-rw-r--r--app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild b/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
new file mode 100644
index 000000000000..21d8c13f5031
--- /dev/null
+++ b/app-dicts/myspell-de_1901/myspell-de_1901-20160403.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MYSPELL_DICT=(
+ "de_DE_1901.aff"
+ "de_DE_1901.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_de_DE_1901.dic"
+)
+
+MYSPELL_THES=(
+)
+
+inherit myspell-r2
+
+DESCRIPTION="German (traditional orthography) dictionaries for myspell/hunspell"
+HOMEPAGE="http://www.j3e.de/myspell/
+ http://extensions.libreoffice.org/extension-center/german-de-de-1901-old-spelling-dictionaries"
+#SRC_URI="http://extensions.libreoffice.org/extension-center/german-de-de-1901-old-spelling-dictionaries/pscreleasefolder.2011-11-04.1209635399/${PV:0:4}.${PV:4:2}.${PV:6:2}/dict-de_de-1901_oldspell_${PV:0:4}-${PV:4:2}-${PV:6:2}.oxt"
+SRC_URI="mirror://sourceforge/project/aoo-extensions/1057/8/dict-de_de-1901_oldspell_${PV:0:4}-${PV:4:2}-${PV:6:2}.oxt"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+src_prepare() {
+ default
+ # Nicely rename; http://www.iana.org/assignments/language-subtag-registry
+ mv de_DE_OLDSPELL.aff de_DE_1901.aff || die
+ mv de_DE_OLDSPELL.dic de_DE_1901.dic || die
+ mv hyph_de_DE_OLDSPELL.dic hyph_de_DE_1901.dic || die
+ # Remove thesaurus for new spelling to avoid installing its readme file
+ rm th_de_DE_v2* || die
+}