summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-dicts/myspell-de/myspell-de-2017.01.12.ebuild')
-rw-r--r--app-dicts/myspell-de/myspell-de-2017.01.12.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild b/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
new file mode 100644
index 000000000000..2c8b8196168f
--- /dev/null
+++ b/app-dicts/myspell-de/myspell-de-2017.01.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYSPELL_DICT=(
+ "de_AT.aff"
+ "de_AT.dic"
+ "de_DE.aff"
+ "de_DE.dic"
+ "de_CH.aff"
+ "de_CH.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_de_AT.dic"
+ "hyph_de_DE.dic"
+ "hyph_de_CH.dic"
+)
+
+MYSPELL_THES=(
+ "th_de_AT_v2.dat"
+ "th_de_AT_v2.idx"
+ "th_de_DE_v2.dat"
+ "th_de_DE_v2.idx"
+ "th_de_CH_v2.dat"
+ "th_de_CH_v2.idx"
+)
+
+inherit myspell-r2
+
+MY_PV=$(ver_rs 1- -) # YYYY-MM-DD
+
+DESCRIPTION="German (AT,CH,DE) dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries
+ https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries
+ https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries
+"
+SRC_URI="
+ https://extensions.libreoffice.org/extensions/german-de-at-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_AT-frami_${MY_PV}.oxt
+ https://extensions.libreoffice.org/extensions/german-de-ch-frami-dictionaries/$(ver_rs 1 -)/@@download/file/dict-de_CH-frami_${MY_PV}.oxt
+ https://extensions.libreoffice.org/extensions/german-de-de-frami-dictionaries/${MY_PV}/@@download/file/dict-de_DE-frami_${MY_PV}.oxt
+"
+
+LICENSE="GPL-3 GPL-2 LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+src_prepare() {
+ # fixing file names
+ for i in *_frami.*; do
+ mv "${i}" "${i/_frami}" || die
+ done
+
+ default
+}