summaryrefslogtreecommitdiff
path: root/app-dicts/dictd-vera/dictd-vera-1.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-dicts/dictd-vera/dictd-vera-1.24.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-dicts/dictd-vera/dictd-vera-1.24.ebuild')
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.24.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/dictd-vera-1.24.ebuild b/app-dicts/dictd-vera/dictd-vera-1.24.ebuild
new file mode 100644
index 000000000000..382ad1a157a1
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+PATCHES=(
+ "${FILESDIR}"/${P}-U+D7.patch
+)
+
+src_compile() {
+ cat vera.[0-9a-z] | dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ dictzip -v vera.dict || die
+}
+
+src_install() {
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+
+ dodoc changelog README
+}