summaryrefslogtreecommitdiff
path: root/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/dictd-vera/dictd-vera-1.23.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/dictd-vera/dictd-vera-1.23.ebuild')
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.23.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/dictd-vera-1.23.ebuild b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
new file mode 100644
index 000000000000..fb0b405a0537
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+
+src_compile () {
+# sed -f debian/dict-vera/sedfile vera.? >vera1 || die
+# sed '1,2!s/^/ /' vera. > vera || die
+# cat vera1>>vera || die
+ cat vera.[0-9a-z] | /usr/bin/dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ /usr/bin/dictzip -v vera.dict || die
+}
+
+src_install () {
+ dodir /usr/lib/dict
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+ dodoc changelog README
+}