summaryrefslogtreecommitdiff
path: root/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/canna-2ch/canna-2ch-20040519.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/canna-2ch/canna-2ch-20040519.ebuild')
-rw-r--r--app-dicts/canna-2ch/canna-2ch-20040519.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-dicts/canna-2ch/canna-2ch-20040519.ebuild b/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
new file mode 100644
index 000000000000..6884138e5dfd
--- /dev/null
+++ b/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cannadic
+
+DESCRIPTION="Japanese Canna dictionary for 2channelers"
+HOMEPAGE="http://omaemona.sourceforge.net/packages/Canna"
+SRC_URI="https://dev.gentoo.org/~naota/files/${P}.tar.gz"
+#SRC_URI="http://omaemona.sourceforge.net/packages/Canna/2ch.t"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm64 hppa ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="canna"
+
+DEPEND="canna? ( app-i18n/canna )"
+S="${WORKDIR}/${PN}"
+
+CANNADICS="2ch"
+DICSDIRFILE="${FILESDIR}/052ch.dics.dir"
+
+src_compile() {
+ # Anthy users do not need binary dictionary
+ if use canna; then
+ mkbindic nichan.ctd || die
+ fi
+}