summaryrefslogtreecommitdiff
path: root/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/canna-2ch/canna-2ch-20040519.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/canna-2ch/canna-2ch-20040519.ebuild')
-rw-r--r--app-dicts/canna-2ch/canna-2ch-20040519.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-dicts/canna-2ch/canna-2ch-20040519.ebuild b/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
new file mode 100644
index 000000000000..d6b5eb2ddbda
--- /dev/null
+++ b/app-dicts/canna-2ch/canna-2ch-20040519.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cannadic
+
+DESCRIPTION="Japanese Canna dictionary for 2channelers"
+HOMEPAGE="http://omaemona.sourceforge.net/packages/Canna"
+SRC_URI="https://dev.gentoo.org/~naota/files/${P}.tar.gz"
+#SRC_URI="http://omaemona.sourceforge.net/packages/Canna/2ch.t"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="canna"
+
+DEPEND="canna? ( app-i18n/canna )"
+S="${WORKDIR}/${PN}"
+
+CANNADICS="2ch"
+DICSDIRFILE="${FILESDIR}/052ch.dics.dir"
+
+src_compile() {
+ # Anthy users do not need binary dictionary
+ if use canna; then
+ mkbindic nichan.ctd || die
+ fi
+}