summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 11:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 11:12:20 +0100
commit7aa28e7310855bc5ef0d32b22e8b58eec55c28c9 (patch)
tree9ceae60214a212f74f44e47506754fdeafb6947a /app-crypt
parent2099ff9b640e648be67527e29760263a7c6274e5 (diff)
gentoo auto-resync : 28:04:2023 - 11:12:20
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin24953 -> 24954 bytes
-rw-r--r--app-crypt/tpm2-abrmd/Manifest1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild64
3 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 6acfa70c1d68..aa0e3b0677bc 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/tpm2-abrmd/Manifest b/app-crypt/tpm2-abrmd/Manifest
index a76f7bf7558f..8b41218c1913 100644
--- a/app-crypt/tpm2-abrmd/Manifest
+++ b/app-crypt/tpm2-abrmd/Manifest
@@ -4,4 +4,5 @@ DIST tpm2-abrmd-2.4.1.tar.gz 577259 BLAKE2B 7d97e1069a171f3693fb11b8e2ce0243993f
DIST tpm2-abrmd-3.0.0.tar.gz 576822 BLAKE2B cdcb677a2dec59cdc454b98793bb0784ba3403c276b618cd37c5748ab1d883ee8f3f69c0ae95c7bf262e2e993dcc0b12ae39010de12c6c211fe3de8c21515160 SHA512 65a39cd0518dfbcbd5835ac6c6628444d412e36471702f2cd1f1077d788330a477778e6403899ea2fa0497b643e5db9ca3e746845492eff78c4c78d8dd8f9e7d
EBUILD tpm2-abrmd-2.4.1-r1.ebuild 1580 BLAKE2B 9598e8a6d2b1dd25cffd6bc23c2fe6c68369dbba39a584101a8b65a743eae09e3ac6aee930517e8c6fedd4f83f451f531ac254fb132687210d074159aa5169f9 SHA512 b46319faf9d9b8b5e626afcbdc30fbdc88a1f0660fc11f38eb9cc4ed3ac8e7d2e835318d732463de6580765effb0bd2faf48c5c91662b21b7bc1582fb3366722
EBUILD tpm2-abrmd-3.0.0-r1.ebuild 1462 BLAKE2B 485c7377a0ad59718f678fed16492b3330d58f14b8d226beeead3712b39462f1d93916b29fc4bca791e8beea098034324d823eb8698911bab599bf396872a0e4 SHA512 7665df2ddf3106c58de354324cfce3489ee7a5be5e9edf148fba5148bbd74261672aef2402dc88c2b5b31a99b0e20592c2b4147a02f190cadc3097a4455664f2
+EBUILD tpm2-abrmd-3.0.0-r2.ebuild 1473 BLAKE2B c9c8b0b693190535c88c8bd53809933e479d14bffc3d23fd42d8a2cc5016f630e6cb159d16ab1d00df5b1cb0765d68dcb5210b7f0a3bebcb8f93918cd8c23bab SHA512 ecb78253367225ef7dfa451f364ad37d396f07e14227ba249f3f8fa9e048a45c52824007696788f81da441d5488066929995aa2d7086a6448ed2cee7bced2e19
MISC metadata.xml 493 BLAKE2B fd3fd8c23a18d535957ac767d6f1a8cc49a91ad362d02b3df87e14040d856c7f01341561fed23090b6776937d9cb11e7015d869fc5399620e9047f1644591e9d SHA512 2f72ada33f64c867a9b0a453919d0dbd444ba072abe3212fd6a3c2fb5bd337fb38b6ff0b8474345e6843160822d6c065261881799a9598de3a57045f09208667
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild
new file mode 100644
index 000000000000..27f02d556e9a
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="TPM2 Access Broker & Resource Manager"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ sys-apps/dbus
+ dev-libs/glib:=
+ app-crypt/tpm2-tss:="
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ >=app-crypt/tpm2-tss-3.0.0:=
+ dev-util/cmocka
+ )"
+BDEPEND="virtual/pkgconfig
+ dev-util/gdbus-codegen"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # tests fail with LTO enabbled. See bug 865275
+ filter-lto
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ $(use_enable test integration) \
+ --disable-defaultflags \
+ --with-dbuspolicydir="${EPREFIX}/usr/share/dbus-1/system.d" \
+ --with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
+ --with-systemdpresetdisable \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ einfo "As of tpm2-abrmd 3.0.0, users must be in the tss group"
+ einfo "to access the TPM"
+}