summaryrefslogtreecommitdiff
path: root/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
commit8dfbaa8100b5c51e1de0e4e476ef5513e3ed1bdd (patch)
tree6514153552d2daad7d178ee75d47332710e2979e /app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild
parent2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (diff)
gentoo auto-resync : 07:05:2023 - 23:37:50
Diffstat (limited to 'app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild')
-rw-r--r--app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild
new file mode 100644
index 000000000000..9c1a59dda12c
--- /dev/null
+++ b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Yubico Authenticator for TOTP"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-flutter/
+ https://github.com/Yubico/yubioath-flutter"
+SRC_URI="https://github.com/Yubico/yubioath-flutter/releases/download/${PV}/yubico-authenticator-${PV}-linux.tar.gz"
+S="${WORKDIR}/yubico-authenticator-${PV}-linux"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/glib:2
+ media-libs/libepoxy
+ sys-apps/pcsc-lite
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libxcb
+ x11-libs/pango"
+BDEPEND="app-admin/chrpath"
+
+# "Modern" app, built using Google's flutter framework.
+#
+# Don't even *think* about unbundling the dependencies, they're all
+# hardcoded into the main binary and the helper, including but not
+# limited to a full-fledged python interpreter that gets dlopen'd, an
+# assortment of python packages, the X11 kitchen sink, random GCC
+# libraries, and OpenSSL 1.1, oftentimes using git checkouts instead of
+# released versioned libraries.
+#
+# The only way to avoid this mess would be to build flutter from source,
+# but unfortunately life is too short to be dealing with whatever is
+# Google's framework-de-jour on a regular basis.
+QA_PREBUILT="opt/yubico-authenticator/*"
+
+src_install() {
+ einstalldocs
+ rm -r README* || die
+
+ sed -e 's|@EXEC_PATH/authenticator|authenticator|' \
+ -e 's|@EXEC_PATH/linux_support/com.yubico.yubioath.png|com.yubico.yubioath|g' \
+ -i linux_support/com.yubico.authenticator.desktop || die
+ domenu linux_support/com.yubico.authenticator.desktop
+ doicon -s 128 linux_support/com.yubico.yubioath.png
+ rm -r linux_support || die
+
+ exeinto /opt/yubico-authenticator
+ doexe authenticator
+ rm authenticator || die
+
+ exeinto /opt/yubico-authenticator/helper
+ doexe helper/authenticator-helper
+ rm helper/authenticator-helper || die
+
+ # prevent rpath_security_checks() trigger
+ chrpath -d helper/libjpeg*.so.* || die
+
+ insinto /opt/yubico-authenticator
+ doins -r .
+
+ dosym ../../opt/yubico-authenticator/authenticator /usr/bin/authenticator
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "Make sure you are a member of the pcscd group"
+ elog "and the pcscd service is running."
+}