summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
new file mode 100644
index 000000000000..a1c35da4ab92
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-4.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="ssl"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ dev-python/click[${PYTHON_USEDEP}]
+ <dev-python/cryptography-39[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="test? (
+ dev-python/makefun[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}