summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild b/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
new file mode 100644
index 000000000000..eb81ef9c289d
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-0.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ sys-auth/ykpers
+"