summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /app-crypt/yubikey-manager-qt
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'app-crypt/yubikey-manager-qt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest2
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index a0f1fadcfe90..b7a7d4d5e306 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1,3 +1,5 @@
DIST yubikey-manager-qt-0.4.0.tar.gz 183566 BLAKE2B 2364d0d257ab5c05d0555aba4bb01ee1639a2c3a42b47173ae905945a6265b123985ad7d8fe50b0cfd38a1a0a588f3e1424aa46585ddbf50337ce2456899067e SHA512 12cef9636f06a92fdb3fce7cea5b97af3255b9cdd1b4feb4e184999eb77c17e465db927f56cd0e443a8ce8afc27b7e4be19ed07da7c41259f909ac4e98971de2
+DIST yubikey-manager-qt-0.5.1.tar 655360 BLAKE2B 6b109190750bd9675e32c836831a7e0ea286021303deffc64a351f2a127f5a5ee0190e3ca99abf0407bbb34a1a1c454f453fab464de2726f6cae539d5f865da1 SHA512 a8ceab5fd8d20eca2424d3f9a92ad12066e8fc26a7640df478965e5d9e2896fbc64885b26f599fcb2588f5b64d2f046af373f87e23ef266178ddf877e422ed36
EBUILD yubikey-manager-qt-0.4.0-r2.ebuild 1211 BLAKE2B 50e1f5f13343fd19b9b871f3c15a62bdbdeebddc9721d9aa7ac81de7c3312811d7cec0985e1063fdfa9d13b542cb03e0eace12c01d40c248df04c940fb2cb2d0 SHA512 d0511a033597c2e901736aa73b6b840fec03adabdda384a026ad4047be0d5ad0a3373ea2519b62e91efb0d864129d5d14a571a351ffc03477b899349985da64c
+EBUILD yubikey-manager-qt-0.5.1.ebuild 1445 BLAKE2B b11dd07d657c4e61f284d733ddcc71a3a2a0860a39b0a8d6ae9f3895cda38922dacb3816cd4464c91664f456e8edaf2b06175a07b1c8ad0d68cc2a616f00c881 SHA512 6beafa82aa84056534d0a99dac7438da46f7d9fd3328b220c39fed6da7da6c24239c8d2e68c48a994d6b691d4fc7ea832fae953243b6138df078ae16e0d226d2
MISC metadata.xml 257 BLAKE2B fd7fdb57fdce3a565a08cedc4d99216724e4013515d77ea89cb41a5c01e8f5479cab25fe53d44a705e3a71164cdc3c93e658e61deae654a13e5c2471dd83c57c SHA512 35e59430f93d3bb2e7e3042a2464b84f8e6cdf1e1624c1e7674bfc5147f9b9694da6b39ac081ed5fc22f1623aea889b743cfee11007911f3c8c17cf61443675b
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.1.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.1.ebuild
new file mode 100644
index 000000000000..b9627b57544b
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit eutils qmake-utils python-single-r1
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+# >yubikey-manager-qt-0.5.1 should have the tarball issue fixed: https://github.com/Yubico/yubikey-manager-qt/issues/49
+SRC_URI="https://github.com/Yubico/yubikey-manager-qt/releases/download/${P}/${P}.tar.gz -> ${P}.tar"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=app-crypt/yubikey-manager-0.7.0[${PYTHON_USEDEP}]
+ <app-crypt/yubikey-manager-0.8
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyotherside[${PYTHON_USEDEP}]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtsvg:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/qtsingleapplication.pri/d" \
+ -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}