summaryrefslogtreecommitdiff
path: root/app-crypt/yubihsm-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 17:30:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 17:30:28 +0100
commitdebb2c431b40a6b4750a39956cc5fcfa5a4a6476 (patch)
tree5c5fceb399f1dddaf02d4d8da8f674106cede374 /app-crypt/yubihsm-shell
parenta17b25a10359070f9527893d861369d378021aa9 (diff)
gentoo auto-resync : 07:04:2023 - 17:30:27
Diffstat (limited to 'app-crypt/yubihsm-shell')
-rw-r--r--app-crypt/yubihsm-shell/Manifest3
-rw-r--r--app-crypt/yubihsm-shell/metadata.xml11
-rw-r--r--app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-shell/Manifest b/app-crypt/yubihsm-shell/Manifest
new file mode 100644
index 000000000000..0f00190d1d71
--- /dev/null
+++ b/app-crypt/yubihsm-shell/Manifest
@@ -0,0 +1,3 @@
+DIST yubihsm-shell-2.4.0.tar.gz 334956 BLAKE2B 93a86baa1e463aa5200e31e9cc657642f37e05ec6e9897bb35f0b518df83b38c69e365766170d76aeeae6da357f3c2fce736c03665861c7ed4f2b56805a7eb3a SHA512 2b08e6e8932ff3bc12d1233d88147264a9875ce145290e29fb6b8f25eeb8e502afff9e7d02714a50454b85b0f01b09c0321d830a483d6b4f7afb962adce882d5
+EBUILD yubihsm-shell-2.4.0.ebuild 530 BLAKE2B d25cbe902c01c2178cc93a61fd9d583faea45b342b1154d07e2fae0eaff9657761182ffb79e4094ed6d03bf894be45c5f8562b537dce9f2b4ff9b6ecacdfe129 SHA512 451504879db0bb00531770a7736c7c3e2c8eddf0ba84d6578c768baf12c336ccb9fe3fbe64d43273e496f0c86ef725677faa3b71ca5d2c188b7edcf214687490
+MISC metadata.xml 336 BLAKE2B 1c5a26c43beeee9fc1497c1444d100bd932ecf9c67b0601451caeee362a9bd408d6135f10cfe333c82832021fad86f6f0f39aa5fad26b9fa49fbb5b993903e86 SHA512 f560dfcedb27bf5cb2ab2ae5157702b047636c10e7a763357ba9d2dd23664296a03c2dc4652adc10393a1acac23ff9533c461b4dc7f64a1d96d05d9a18551277
diff --git a/app-crypt/yubihsm-shell/metadata.xml b/app-crypt/yubihsm-shell/metadata.xml
new file mode 100644
index 000000000000..2914927d575f
--- /dev/null
+++ b/app-crypt/yubihsm-shell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubihsm-shell</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
new file mode 100644
index 000000000000..6ff4ec262044
--- /dev/null
+++ b/app-crypt/yubihsm-shell/yubihsm-shell-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Components used to interact with the YubiHSM 2"
+HOMEPAGE="https://developers.yubico.com/yubihsm-shell/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:=
+ net-misc/curl
+ dev-libs/libedit
+ virtual/libusb:1
+ sys-apps/pcsc-lite
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gengetopt
+ virtual/pkgconfig
+"