summaryrefslogtreecommitdiff
path: root/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild')
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
new file mode 100644
index 000000000000..379db39defbc
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc
+}
+
+src_install() {
+ dobin xor-analyze xor-enc
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}