summaryrefslogtreecommitdiff
path: root/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch')
-rw-r--r--app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch b/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch
new file mode 100644
index 000000000000..41fc6d521c66
--- /dev/null
+++ b/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch
@@ -0,0 +1,26 @@
+From 181857089b11045c701e9195275a408430beb580 Mon Sep 17 00:00:00 2001
+From: Mounir IDRASSI <mounir.idrassi@idrix.fr>
+Date: Sat, 5 Nov 2016 23:39:46 +0100
+Subject: [PATCH] Linux: Always use "uname -m" to determine processor type.
+ This fixes Slackware build issue.
+
+---
+ src/Makefile | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 7bfc5ad..00e6e5b 100644
+--- src/Makefile
++++ src/Makefile
+@@ -131,10 +131,7 @@ export PLATFORM_UNSUPPORTED := 0
+ export CPU_ARCH ?= unknown
+ export SIMD_SUPPORTED := 0
+
+-ARCH = $(shell uname -p)
+-ifeq "$(ARCH)" "unknown"
+- ARCH = $(shell uname -m)
+-endif
++ARCH = $(shell uname -m)
+
+ ifneq (,$(filter i386 i486 i586 i686 x86,$(ARCH)))
+ CPU_ARCH = x86