summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tss
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-crypt/tpm2-tss
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-crypt/tpm2-tss')
-rw-r--r--app-crypt/tpm2-tss/Manifest3
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.2.3-r1.ebuild55
-rw-r--r--app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild1
3 files changed, 58 insertions, 1 deletions
diff --git a/app-crypt/tpm2-tss/Manifest b/app-crypt/tpm2-tss/Manifest
index 8c077b2f6674..4932b209c7cc 100644
--- a/app-crypt/tpm2-tss/Manifest
+++ b/app-crypt/tpm2-tss/Manifest
@@ -1,3 +1,4 @@
DIST tpm2-tss-2.2.3.tar.gz 912179 BLAKE2B 36b2a462512822dccb3adab605ea9922132f027455a1d2895b6735f6200fe44f08288477c99afd0f6c06b4bff3090104b6412b12ea4a518888cf756fb8ee53c4 SHA512 68087cbf2b7acc33788e90b3825bf2c91faa65cfc04b576790634c88876a8a6930d6943f83b7cf0858e37e5e7307703d0c975b9fc0b0ad1d87f66c74b65bd411
-EBUILD tpm2-tss-2.2.3.ebuild 1274 BLAKE2B 60f825e8f666b4bd89b01a54d9b0c0802bd0e2bc733060e4c1cd4a5d34f881bd19c33bf6e36b7d31795eaf1fa527f9fd30c8618671fad16f020a11f8357ec036 SHA512 50e563c5fe26f5c223e56d7542d92a60ca68134722a662373eba50ae0f70ce2efdee61cb5073ca8de0779d1657579a3b0ad76f967798c15ac0d0440e8c53c0dd
+EBUILD tpm2-tss-2.2.3-r1.ebuild 1275 BLAKE2B 668138a018c9e3d811c941265f555f0b835d2a0f3e35a30efa280bb36fbdd9707193c23728448bc8be7b03f1759133f69b7f718de42b714b11f7af368da264f5 SHA512 f40fe96f4ad6427abe10c8573deb16586c2a48455af487b7eaba427b1cfac00847dfb316037600fafb18fb731fa7fbb631b87dca0a1f8d43e23ca4889d6e0f9a
+EBUILD tpm2-tss-2.2.3.ebuild 1301 BLAKE2B ff9463239c9aca960b72a15340a2b596a1587feef28dee9452cb80d6e8530ca32250e41daca16580e0708d23f91ab41bf942b83fc8db5e994a91e98da00f68cb SHA512 33ec0d577320a4ad115310cdee5fb4f975756c509a0f9d5f714d15b6e6dc79a53263090af851caf78ffd464b0e874966bccf238c02ff8d885067bd3a76f65371
MISC metadata.xml 501 BLAKE2B be53401663c21ea24b8fd7a898a30b398c5773d86b5f30cf9a8c4b2334736e09b64ea60e2f6069b765d7babc5695b64a8b38aa3020d65ff224910eb633d76ae6 SHA512 901b9e66b98cea1ee90c8f885f402d66d7fb90494d9b95a2028e4834d5750edb4945563275def32f3944f4e28ba5a3aa558abf3ffce935df1af316cb1cb1d865
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.2.3-r1.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..e2b86a17e071
--- /dev/null
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.2.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info udev
+
+DESCRIPTION="TCG Trusted Platform Module 2.0 Software Stack"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0" # sublot is libtss2-sys number
+KEYWORDS="~amd64"
+IUSE="doc +gcrypt openssl static-libs test"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ gcrypt? ( !openssl )
+ openssl? ( !gcrypt )
+ || ( gcrypt openssl )"
+
+RDEPEND="gcrypt? ( dev-libs/libgcrypt:0= )
+ openssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+ acct-group/tss
+ acct-user/tss
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~TCG_TPM
+ "
+ linux-info_pkg_setup
+ kernel_is ge 4 12 0 || ewarn "At least kernel 4.12.0 is required"
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc doxygen-doc) \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --with-crypto="$(usex gcrypt gcrypt ossl)" \
+ --with-udevrulesdir="$(get_udevdir)/rules.d" \
+ --with-udevrulesprefix=60-
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild b/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
index 8496a3630e8c..7743ba624f99 100644
--- a/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
+++ b/app-crypt/tpm2-tss/tpm2-tss-2.2.3.ebuild
@@ -13,6 +13,7 @@ LICENSE="BSD-2"
SLOT="0/0" # sublot is libtss2-sys number
KEYWORDS="~amd64"
IUSE="doc +gcrypt openssl static-libs test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="
gcrypt? ( !openssl )