summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild')
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..a737e7269f55
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss-engine"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/tpm2-tss:=
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static \
+ --with-completionsdir="$(get_bashcompdir)"
+}
+
+src_install () {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ dobashcomp bash-completion/*
+}