summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-22 01:55:45 +0000
commitb2c59335bfbeb25c5644f32172e1e9b23c447710 (patch)
tree0e8e19f47e39be0a7b9b06cb86db760c6d6b5965 /app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
parent427ba64bd6bcdd59a1ae9bc7c5cec0299d135413 (diff)
gentoo auto-resync : 22:12:2022 - 01:55:45
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
new file mode 100644
index 000000000000..6b996f725753
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 flag-o-matic python-any-r1
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/tpm2-tools/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+fapi test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/tpm2-tss-3.0.1:=[fapi?]
+ dev-libs/openssl:=
+ net-misc/curl
+ sys-libs/efivar:="
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ app-crypt/tpm2-abrmd
+ dev-util/cmocka
+ )"
+BDEPEND="virtual/pkgconfig
+ sys-devel/autoconf-archive
+ test? (
+ app-editors/vim-core
+ dev-tcltk/expect
+ $(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ # tests fail with LTO enabbled. See bug 865275 and 865277
+ filter-lto
+ econf \
+ $(use_enable fapi) \
+ $(use_enable test unit) \
+ --with-bashcompdir=$(get_bashcompdir) \
+ --enable-hardening
+}
+
+src_install() {
+ default
+ mv "${ED}"/$(get_bashcompdir)/tpm2{_completion.bash,} || die
+ local utils=( "${ED}"/usr/bin/tpm2_* )
+ bashcomp_alias tpm2 "${utils[@]##*/}"
+}