summaryrefslogtreecommitdiff
path: root/app-crypt/ssss
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-crypt/ssss
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-crypt/ssss')
-rw-r--r--app-crypt/ssss/Manifest4
-rw-r--r--app-crypt/ssss/metadata.xml3
-rw-r--r--app-crypt/ssss/ssss-0.5.6.ebuild39
3 files changed, 45 insertions, 1 deletions
diff --git a/app-crypt/ssss/Manifest b/app-crypt/ssss/Manifest
index 05714d7c5075..49e54af6e6d9 100644
--- a/app-crypt/ssss/Manifest
+++ b/app-crypt/ssss/Manifest
@@ -1,3 +1,5 @@
+DIST ssss-0.5.6.tar.gz 20128 BLAKE2B d42fff5878e2ebcc62cd86b86f0f8a3e522c089cbb5e8fb2585cf375ff133da7d9ccf00e62cc6888e00abe5d64f87ac19ddbb3f6e6a0d86913e6a6aa5a8a1d4c SHA512 964af01610a7a269d19ae1fa1712ef12ca1afab02636ba83dd84ec5aeb185210a1247d932ee39d2869aa76e54ffb051d802800d295d17355d6fe2a8010edd509
DIST ssss-0.5.tar.gz 17435 BLAKE2B 76aae463ce11341f8b0336526f7d19c9921025cabc05bc9e00005b0bdeb676ed5e069226962232f277de2fecb1cd71bafbd4b2fa0c03ef4faf0f66daa24599d1 SHA512 be8df1666ac61d4097b5fd54f2cee3640db8f85ec21411f1b208a35b671c5699bc692079525d8d313d1cf2500da31bfb03771829a9fdccc0bb6d806749526ec9
EBUILD ssss-0.5-r1.ebuild 774 BLAKE2B 08fa8b0d2c88ba22cb3a74bd728a32c2e54ff9cd92b88c8345e407b035bc2916f547ed18ab90d76efb401e6cd7aa015f0262bdb9b9629039091aef5c19725dd6 SHA512 364456d49bf4625c632e42dfee4013b84cb4dee6df747b113dcc11362c4bbb9cbbc2c5b460411986c751c4fd0a4c34a288464b383601bc2eb6c331ad295224f8
-MISC metadata.xml 496 BLAKE2B 0e998a8a5587315750394702193fa739a61bcc5101f38eca3b25f13af0661b54f76ad214fc0e378cc55a7a99192e3c7f75166eedda18ab61c1d9911830f40b6c SHA512 84249ac824f19a308cc20bde7610c829030c363c13c6111bfe30d7d5a219461728a8f6010bb006821be5ede4a2cf02c3e11eee67d782126ef0e1453207298c66
+EBUILD ssss-0.5.6.ebuild 810 BLAKE2B 353efe544e4d85bf4cb3d7c400fbb9c9d351efd30aa50a276838db169add2c5c2ff01dbe742722c96dd65cef569314111305a65874422b803efda80f55274b29 SHA512 f1133c11c1c54777ab0ece70c2dabcec82cd599ba95c063648255aad6aeb2d55d6876bbace45d3aa754b08b4c1a8795bba443538aeaea7c56e86724422765efe
+MISC metadata.xml 571 BLAKE2B 8e5b2a9efdbac1e9cf15c2e7c60e6c6a9c41300a6ec65df5751043ac85536ba31ace97f033aac89e47f9792b8003c134e1b8a8c3af6513e3406e38027d413e42 SHA512 daebb2e758087ee3cb49c5c89c0bafe3bdf57e2f7c3b64e1053e465b765ad8e95594065a7e236cf8072a406f7d92702a84807393820fcaec26ff29bee73ceff6
diff --git a/app-crypt/ssss/metadata.xml b/app-crypt/ssss/metadata.xml
index 51c92c834b21..caba2e85d1bb 100644
--- a/app-crypt/ssss/metadata.xml
+++ b/app-crypt/ssss/metadata.xml
@@ -10,4 +10,7 @@
The program suite does both: the generation of shares for a known secret,
and the reconstruction of a secret using user-pro‐vided shares.
</longdescription>
+ <upstream>
+ <remote-id type="github">MrJoy/ssss</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-crypt/ssss/ssss-0.5.6.ebuild b/app-crypt/ssss/ssss-0.5.6.ebuild
new file mode 100644
index 000000000000..724f2c160f99
--- /dev/null
+++ b/app-crypt/ssss/ssss-0.5.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="https://github.com/MrJoy/ssss"
+SRC_URI="https://github.com/MrJoy/${PN}/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-releases-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/xmltoman"
+
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ # Respect users [CL]FLAGS and don't strip, as portage does this part
+ sed -e 's/-O2/$(CFLAGS) -lgmp $(LDFLAGS)/g' -e '/strip/d' -i Makefile || die
+}
+
+src_install() {
+ dobin ssss-split
+ dosym ssss-split /usr/bin/ssss-combine
+
+ doman ssss.1
+
+ einstalldocs
+}