summaryrefslogtreecommitdiff
path: root/app-crypt/ssss/ssss-0.5.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-crypt/ssss/ssss-0.5.7-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-crypt/ssss/ssss-0.5.7-r1.ebuild')
-rw-r--r--app-crypt/ssss/ssss-0.5.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/ssss/ssss-0.5.7-r1.ebuild b/app-crypt/ssss/ssss-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..ce73f8924357
--- /dev/null
+++ b/app-crypt/ssss/ssss-0.5.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="https://github.com/MrJoy/ssss"
+SRC_URI="https://github.com/MrJoy/${PN}/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-releases-v${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/xmltoman"
+
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ # Respect users [CL]FLAGS and don't strip, as portage does this part
+ sed -e 's/-O2/$(CFLAGS) -lgmp $(LDFLAGS)/g' -e '/strip/d' -i Makefile || die
+}
+
+src_install() {
+ dobin ssss-split
+ dosym ssss-split /usr/bin/ssss-combine
+
+ doman ssss.1
+
+ einstalldocs
+}