summaryrefslogtreecommitdiff
path: root/app-crypt/scute/scute-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/scute/scute-1.5.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/scute/scute-1.5.0.ebuild')
-rw-r--r--app-crypt/scute/scute-1.5.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/scute/scute-1.5.0.ebuild b/app-crypt/scute/scute-1.5.0.ebuild
new file mode 100644
index 000000000000..85adede2192a
--- /dev/null
+++ b/app-crypt/scute/scute-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="mirror://gnupg/scute/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/pkcs11 \
+ --with-gpgsm=/usr/bin/gpgsm
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}