summaryrefslogtreecommitdiff
path: root/app-crypt/sbctl/sbctl-0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-26 01:33:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-26 01:33:45 +0000
commit15bb7733ddb1f16a0e3936969282ecc42419829a (patch)
tree56c720cc03bec3e9758966b4083b5916feca6962 /app-crypt/sbctl/sbctl-0.13.ebuild
parent026061ba423025e6713112920f290759cdee03c4 (diff)
gentoo auto-resync : 26:12:2023 - 01:33:45
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.13.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.13.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/sbctl/sbctl-0.13.ebuild b/app-crypt/sbctl/sbctl-0.13.ebuild
new file mode 100644
index 000000000000..6d78f5f02945
--- /dev/null
+++ b/app-crypt/sbctl/sbctl-0.13.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module verify-sig
+
+DESCRIPTION="Secure Boot key manager"
+HOMEPAGE="https://github.com/Foxboron/sbctl"
+SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc
+ verify-sig? ( sec-keys/openpgp-keys-foxboron )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/foxboron.asc"
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
+ fi
+
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+}