summaryrefslogtreecommitdiff
path: root/app-crypt/rotix/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/rotix/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/rotix/files')
-rw-r--r--app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch31
-rw-r--r--app-crypt/rotix/files/rotix-0.83-interix.patch15
-rw-r--r--app-crypt/rotix/files/rotix-0.83-locale.diff10
3 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
new file mode 100644
index 000000000000..ab23372e768f
--- /dev/null
+++ b/app-crypt/rotix/files/0.83-respect-CFLAGS-and-dont-strip.patch
@@ -0,0 +1,31 @@
+Index: rotix-0.83/Makefile
+===================================================================
+--- rotix-0.83.orig/Makefile
++++ rotix-0.83/Makefile
+@@ -22,12 +22,6 @@
+
+ include Makefile.settings
+
+-ifdef DEBUG
+-CFLAGS += -g3
+-else
+-CFLAGS += -O3
+-endif
+-
+ ifdef I18N
+ CFLAGS += -DPACKAGE=\"${PACKAGE}\" -D LOCALEDIR=\"${LOCALE}\"
+ endif
+@@ -39,12 +33,7 @@ endif
+ all : rotix po
+
+ rotix : rot.o help.o rotix.o
+- $(CC) -Wall $(CFLAGS) -o rotix rot.o help.o rotix.o
+-ifdef STRIP
+-ifndef DEBUG
+- $(STRIP) rotix
+-endif
+-endif
++ $(CC) -Wall $(CFLAGS) $(LDFLAGS) -o rotix rot.o help.o rotix.o
+
+ ifdef I18N
+ CFLAGS += -D I18N=1
diff --git a/app-crypt/rotix/files/rotix-0.83-interix.patch b/app-crypt/rotix/files/rotix-0.83-interix.patch
new file mode 100644
index 000000000000..b691478582ca
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-interix.patch
@@ -0,0 +1,15 @@
+--- rotix-0.83.orig/help.c
++++ rotix-0.83/help.c
+@@ -24,8 +24,12 @@
+ * I18N
+ \*/
+
++#if I18N
+ #include <libintl.h>
+ #define _(String) gettext (String)
++#else
++#define _(String) (String)
++#endif
+
+ /*\
+ * This function displays the help-information.
diff --git a/app-crypt/rotix/files/rotix-0.83-locale.diff b/app-crypt/rotix/files/rotix-0.83-locale.diff
new file mode 100644
index 000000000000..844a452b8af1
--- /dev/null
+++ b/app-crypt/rotix/files/rotix-0.83-locale.diff
@@ -0,0 +1,10 @@
+--- rotix.c 2002-04-02 14:48:42.000000000 -0500
++++ rotix.c.mine 2010-07-15 14:54:45.000000000 -0400
+@@ -38,6 +38,7 @@
+ /* I18N */
+ #ifdef I18N
+ #include <libintl.h>
++#include <locale.h>
+ #define _(String) gettext (String)
+ #else
+ #define _(String) String