summaryrefslogtreecommitdiff
path: root/app-crypt/pesign
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /app-crypt/pesign
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'app-crypt/pesign')
-rw-r--r--app-crypt/pesign/Manifest3
-rw-r--r--app-crypt/pesign/files/pesign-113-enum-conversion.patch46
-rw-r--r--app-crypt/pesign/pesign-113.ebuild26
3 files changed, 64 insertions, 11 deletions
diff --git a/app-crypt/pesign/Manifest b/app-crypt/pesign/Manifest
index a3a9729bbcb3..bb268851197a 100644
--- a/app-crypt/pesign/Manifest
+++ b/app-crypt/pesign/Manifest
@@ -1,4 +1,5 @@
+AUX pesign-113-enum-conversion.patch 1571 BLAKE2B b1e8f90a220ba7dbdba9d16c1c568fed6e463f8d550b678d85d6c806bc451a023d989ad0830075a4e4b28411685e29d60c5c887d3af100b85a048dcff0a103c0 SHA512 cfa001265bfda5428ef72134d05ec16bee679a3906832aab4100f2c567f22e62d089b8cd475b9707926485c30958e70ba48c4035e118c480d008114fb6876c62
AUX pesign-113-nss.patch 2092 BLAKE2B f75730c2ab48f0ff6af4237fc46c535b3ceead357e31a548c28b78648fec7d52a5cc1bc9dfdb9db4e6cf22b7312cc452afb04a3088810140055ae88b55fb2f1d SHA512 7a4ebd4c875cf6678a6d2ca4083eafea552259e2c1692d167d0b948ac73d50244db3feea1c6d7c403e152236421609da5d92cd6405fb3107e1c3933c2f94fece
DIST pesign-113.tar.gz 124618 BLAKE2B 36cdface6ecdf9003251da3058b21b2ee8e94eb655e47a8668b38c4ea576d990a71860952eea277d5e029bb007039c8e3ded9918e89d47f6db404423acbd1cc7 SHA512 e71dc90c2ab8085d1b000c0d2cf9cb00ddaed1ea1393db75c2d19a96f1b1c188a26b76850533ba97ec254a3b48db6b07a69b597c329ac891e64422780a358c24
-EBUILD pesign-113.ebuild 1139 BLAKE2B c0460e8597f0130f0a6f79ff239dd6e8393f69fa016d023c8088eb37ed933fdbd797855167ba81899dbd0fc4ac83177988743ec18c05a1b0ad237ebe6a26c3a4 SHA512 c59ce37beac4016a0e2e8a111cd1ce943fa6a2be6ee0df2bfbc0e95cfb7670a8dbd772f953ba856c254734dd797c9c1d90f3e923188b23fed1e6d41f45138eb0
+EBUILD pesign-113.ebuild 1182 BLAKE2B 5156252a8ae8c0daa0ff71d137730dd49bbea4886787bbe5c2e739664fc2a8a258278b0dcf622a6916574e6094083a52ce3e82f21f82b5eb778dc19f19215e37 SHA512 fdf7da756a4e363742d55d6eff933c5f70d1f77dbc2169f426fbec7acd3f31cdb493a45f17abe3f0180b85d02bc3df3a1621b05dc4208306f722f1dc2fbffb59
MISC metadata.xml 248 BLAKE2B 53654091f15005bbc49262b840fd687c88b36450646c7639f9767a891a973f393dbbdc093143b3b120e50b1263e383d674e227c44de4c204b34a3a7892ed59e7 SHA512 c77276afdf688db707b87d976aa741c359c9152d0de1ffbdb9d3202a3b62aa2797cd8beb86354dad9fa2158be17948f53995ab9b92ea04ef79e6dd8ac3ede1fa
diff --git a/app-crypt/pesign/files/pesign-113-enum-conversion.patch b/app-crypt/pesign/files/pesign-113-enum-conversion.patch
new file mode 100644
index 000000000000..89a57e460fbe
--- /dev/null
+++ b/app-crypt/pesign/files/pesign-113-enum-conversion.patch
@@ -0,0 +1,46 @@
+From c555fd74c009242c3864576bd5f17a1f8f4fdffd Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Tue, 18 Feb 2020 16:28:56 -0500
+Subject: [PATCH] pesigcheck: Fix a wrong assignment
+
+gcc says:
+
+ pesigcheck.c: In function 'check_signature':
+ pesigcheck.c:321:17: error: implicit conversion from 'enum <anonymous>' to 'enum <anonymous>' [-Werror=enum-conversion]
+ 321 | reason->type = siBuffer;
+ | ^
+ pesigcheck.c:333:17: error: implicit conversion from 'enum <anonymous>' to 'enum <anonymous>' [-Werror=enum-conversion]
+ 333 | reason->type = siBuffer;
+ | ^
+ cc1: all warnings being treated as errors
+
+And indeed, that line of code makes no sense at all - it was supposed to
+be reason->sig.type.
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+---
+ src/pesigcheck.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/pesigcheck.c b/src/pesigcheck.c
+index 524cce3..8fa0f1a 100644
+--- a/src/pesigcheck.c
++++ b/src/pesigcheck.c
+@@ -318,7 +318,7 @@ check_signature(pesigcheck_context *ctx, int *nreasons,
+ reason->type = SIGNATURE;
+ reason->sig.data = data;
+ reason->sig.len = datalen;
+- reason->type = siBuffer;
++ reason->sig.type = siBuffer;
+ nreason += 1;
+ is_invalid = true;
+ }
+@@ -330,7 +330,7 @@ check_signature(pesigcheck_context *ctx, int *nreasons,
+ reason->type = SIGNATURE;
+ reason->sig.data = data;
+ reason->sig.len = datalen;
+- reason->type = siBuffer;
++ reason->sig.type = siBuffer;
+ nreason += 1;
+ has_valid_cert = true;
+ }
diff --git a/app-crypt/pesign/pesign-113.ebuild b/app-crypt/pesign/pesign-113.ebuild
index fcb4a4ab3809..a4d067978175 100644
--- a/app-crypt/pesign/pesign-113.ebuild
+++ b/app-crypt/pesign/pesign-113.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Tools for manipulating signed PE-COFF binaries"
HOMEPAGE="https://github.com/rhboot/pesign"
@@ -12,24 +12,31 @@ SRC_URI="https://github.com/rhboot/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="libressl"
RDEPEND="
dev-libs/nspr
dev-libs/nss
+ dev-libs/openssl:0=
dev-libs/popt
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
sys-apps/util-linux
sys-libs/efivar
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-apps/help2man
sys-boot/gnu-efi
virtual/pkgconfig
"
-PATCHES=( "${FILESDIR}"/${PN}-113-nss.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-113-nss.patch
+ "${FILESDIR}"/${PN}-113-enum-conversion.patch
+)
+
+src_configure() {
+ append-cflags -O1 #721934
+ default
+}
src_compile() {
emake AR="$(tc-getAR)" \
@@ -47,6 +54,5 @@ src_install() {
einstalldocs
# remove some files that don't make sense for Gentoo installs
- rm -rf "${ED%/}/etc/" "${ED%/}/var/" \
- "${ED%/}/usr/share/doc/${PF}/COPYING" || die
+ rm -rf "${ED}/etc" "${ED}/var" "${ED}/usr/share/doc/${PF}/COPYING" || die
}