summaryrefslogtreecommitdiff
path: root/app-crypt/pdfcrack/pdfcrack-0.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-01 21:08:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-01 21:08:07 +0000
commitc37d894982b59595356319a2b4655fed277097ae (patch)
treeca83d38d2302991de53be516dfae53cf09dab271 /app-crypt/pdfcrack/pdfcrack-0.20.ebuild
parentdb16929598ac333b179fdfead630dbdfa68840a5 (diff)
gentoo auto-resync : 01:11:2022 - 21:08:07
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.20.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.20.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.20.ebuild b/app-crypt/pdfcrack/pdfcrack-0.20.ebuild
new file mode 100644
index 000000000000..052aed0a732e
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}