summaryrefslogtreecommitdiff
path: root/app-crypt/onak/onak-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/onak/onak-0.5.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/onak/onak-0.5.0.ebuild')
-rw-r--r--app-crypt/onak/onak-0.5.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/onak/onak-0.5.0.ebuild b/app-crypt/onak/onak-0.5.0.ebuild
new file mode 100644
index 000000000000..f17d1f50f816
--- /dev/null
+++ b/app-crypt/onak/onak-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="onak is an OpenPGP keyserver"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/onak.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb postgres"
+
+DEPEND="berkdb? ( >=sys-libs/db-4 )
+ postgres? ( dev-db/postgresql[server] )"
+
+DOCS=(
+ apache2 README LICENSE onak.sql
+)
+
+# it tries to use all backends?
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local backend="fs"
+ use berkdb && backend="db4"
+ use postgres && backend="pg"
+ if use berkdb && use postgres; then
+ ewarn "berkdb and postgres requested, postgres was preferred"
+ fi
+ econf --localstatedir=/var --enable-backend="${backend}"
+}
+
+src_install() {
+ default
+ insinto /etc
+ doins onak.ini
+ keepdir /var/lib/onak
+ dodir /usr/lib/cgi-bin/pks
+ insinto /usr/lib/cgi-bin/pks
+ doins add gpgwww lookup
+}