summaryrefslogtreecommitdiff
path: root/app-crypt/nasty/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/nasty/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/nasty/files')
-rw-r--r--app-crypt/nasty/files/nasty-0.6-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-crypt/nasty/files/nasty-0.6-flags.patch b/app-crypt/nasty/files/nasty-0.6-flags.patch
new file mode 100644
index 000000000000..522e570a94a8
--- /dev/null
+++ b/app-crypt/nasty/files/nasty-0.6-flags.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,15 +1,16 @@
+ VERSION=0.6
+
+ DEBUG=-g # -pg
+-CFLAGS+=-Wall -O2 -DVERSION=\"${VERSION}\" $(DEBUG)
+-LDFLAGS=-lgpgme $(DEBUG)
++CPPFLAGS+=-DVERSION=\"${VERSION}\" -D_FILE_OFFSET_BITS=64
++CFLAGS+=-Wall $(DEBUG) `gpgme-config --cflags`
++LIBS=`gpgme-config --libs`
+
+ OBJS=nasty.o
+
+ all: nasty
+
+ nasty: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o nasty
++ $(CC) $(LDFLAGS) $(OBJS) -o nasty $(LIBS)
+
+ install: nasty
+ cp nasty /usr/bin