summaryrefslogtreecommitdiff
path: root/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-crypt/monkeysphere/monkeysphere-0.44.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-crypt/monkeysphere/monkeysphere-0.44.ebuild')
-rw-r--r--app-crypt/monkeysphere/monkeysphere-0.44.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/monkeysphere/monkeysphere-0.44.ebuild b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
new file mode 100644
index 000000000000..63b1bd885e78
--- /dev/null
+++ b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Leverage the OpenPGP web of trust for OpenSSH and Web authentication"
+HOMEPAGE="http://web.monkeysphere.info/"
+
+LICENSE="GPL-3"
+SLOT="0/0"
+IUSE=""
+SRC_URI="
+ mirror://debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz
+ http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( README Changelog )
+
+## Tests fail upstream for SSH connection. Issue has been reported.
+RESTRICT="test"
+
+DEPEND="acct-group/monkeysphere
+ acct-user/monkeysphere
+ >=app-crypt/gnupg-2.1.17:0=
+ net-misc/socat:0=
+ dev-perl/Crypt-OpenSSL-RSA:0=
+ dev-perl/Digest-SHA1:0=
+ app-misc/lockfile-progs:0="
+
+RDEPEND="${DEPEND}
+ net-misc/openssh"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.44-install-uncompressed-man-pages.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s#share/doc/monkeysphere#share/doc/${PF}#" \
+ Makefile \
+ || die
+}
+
+pkg_postinst() {
+ monkeysphere-authentication setup
+}