summaryrefslogtreecommitdiff
path: root/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-crypt/monkeysphere/monkeysphere-0.44.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-crypt/monkeysphere/monkeysphere-0.44.ebuild')
-rw-r--r--app-crypt/monkeysphere/monkeysphere-0.44.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-crypt/monkeysphere/monkeysphere-0.44.ebuild b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
index c22ae2b8f88c..f8a6c908946d 100644
--- a/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
+++ b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Leverage the OpenPGP web of trust for OpenSSH and Web authentication"
HOMEPAGE="http://web.monkeysphere.info/"
-
-LICENSE="GPL-3"
-SLOT="0/0"
-IUSE=""
SRC_URI="
mirror://debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz
http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="amd64 ~arm x86"
DOCS=( README Changelog )
-## Tests fail upstream for SSH connection. Issue has been reported.
+# Tests fail upstream for SSH connection. Issue has been reported.
RESTRICT="test"
DEPEND="acct-group/monkeysphere
@@ -26,19 +27,20 @@ DEPEND="acct-group/monkeysphere
dev-perl/Crypt-OpenSSL-RSA:0=
dev-perl/Digest-SHA1:0=
app-misc/lockfile-progs:0="
-
RDEPEND="${DEPEND}
net-misc/openssh"
-PATCHES=( "${FILESDIR}"/${PN}-0.44-install-uncompressed-man-pages.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.44-install-uncompressed-man-pages.patch
+ "${FILESDIR}"/${PN}-0.44-no-werror.patch
+)
src_prepare() {
default
- sed -i \
- -e "s#share/doc/monkeysphere#share/doc/${PF}#" \
- Makefile \
- || die
+ sed -i -e "s#share/doc/monkeysphere#share/doc/${PF}#" Makefile || die
+
+ tc-export CC
}
pkg_postinst() {