summaryrefslogtreecommitdiff
path: root/app-crypt/minisign/minisign-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /app-crypt/minisign/minisign-9999.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'app-crypt/minisign/minisign-9999.ebuild')
-rw-r--r--app-crypt/minisign/minisign-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
new file mode 100644
index 000000000000..da90d6d5d3f4
--- /dev/null
+++ b/app-crypt/minisign/minisign-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"