summaryrefslogtreecommitdiff
path: root/app-crypt/md4sum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/md4sum
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/md4sum')
-rw-r--r--app-crypt/md4sum/Manifest4
-rw-r--r--app-crypt/md4sum/files/md4sum-fix-out-of-bounds-write.diff11
-rw-r--r--app-crypt/md4sum/md4sum-0.02.03-r1.ebuild30
-rw-r--r--app-crypt/md4sum/metadata.xml5
4 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/md4sum/Manifest b/app-crypt/md4sum/Manifest
new file mode 100644
index 000000000000..d5a6e273daaa
--- /dev/null
+++ b/app-crypt/md4sum/Manifest
@@ -0,0 +1,4 @@
+AUX md4sum-fix-out-of-bounds-write.diff 271 BLAKE2B 44573278991d38979ca6f7d18b51be2d9f4150b1491c0650b0ae99d203be475a9c15bfcbdba1dab557a5467aff3c78a16b098d417905b24270164a9969d81ff3 SHA512 bcf06b6da80b67965547d359774c4462516dd69d36ed84723d9baaa93472405ed4d790ce687affa148be39157137ef46399e355540c18271f9164318f7731d65
+DIST md4sum-0.02.03.tar.gz 26819 BLAKE2B 6e7fb76a21d13276a7444e1c1d1d0a05e90399dc7a99b3e2e6d24d1dc46f45b086b99d00e4c9e1821c4a82a9fe985e4823a235e254abba475bd639f98536aea6 SHA512 5a05760aa6a770d9f55a41e42bdf6801dcd67bc804ead5bd84aecc48e5ee5a7c8b01d4a1e1767a4cc1f8695d66ed16c6a1f09b58d236c27db317f227e02e3762
+EBUILD md4sum-0.02.03-r1.ebuild 687 BLAKE2B 8a4c60e60c65bc96603c76dad203ba7323a98ba75b8d7a9fb8a6bbfb854334880f4f71a2312a2fd2c8cb3bdc9b03b08ab12938359e537cc25777050df5cef1a6 SHA512 d6eb35b2f85b0948094f84d0f9b47c5166b3dd4b02ec10bdea8bb5188e25aedf370b2e2425f2f6b9f35d97e2a396e99e2c4843fd3988f3e9168d0081c42783ff
+MISC metadata.xml 210 BLAKE2B a547b5e8dbb5d674ce2df4bcc6ee71c3aae3b0c7863c38a66c1fac3cf0f0c16c7bb302264082f345d2da87d0e544d321e6fd8385a16d01620a733a8ab29082a3 SHA512 27fbc849a311e57c8dbad0cae9975d564c03ae8a7b495b2e7a5cd160c6a09c0101e695ba4d2edf07c0d4c4d7329ff9a4bd91656aa685623342883b83bcb9ac0f
diff --git a/app-crypt/md4sum/files/md4sum-fix-out-of-bounds-write.diff b/app-crypt/md4sum/files/md4sum-fix-out-of-bounds-write.diff
new file mode 100644
index 000000000000..1275996080ee
--- /dev/null
+++ b/app-crypt/md4sum/files/md4sum-fix-out-of-bounds-write.diff
@@ -0,0 +1,11 @@
+--- a/md4sum.c 2007-04-11 23:22:38.000000000 +0200
++++ b/md4sum.c 2015-02-15 21:57:59.699682995 +0100
+@@ -126,7 +126,7 @@
+ int i;
+ static char s[33];
+ for( i=0; i<16; i++ ) sprintf( &s[2*i], "%02x", digest[i] );
+- s[33]= '\0';
++ s[32]= '\0';
+ return( s );
+ }
+
diff --git a/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild b/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
new file mode 100644
index 000000000000..fac751884b0e
--- /dev/null
+++ b/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="md4 and edonkey hash algorithm tool"
+HOMEPAGE="http://linux.xulin.de/c/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/md4sum-fix-out-of-bounds-write.diff"
+}
+
+src_compile() {
+ sed -i -e "s:CFLAGS=:CFLAGS=${CFLAGS} :g" \
+ -e "s:install -s:install:g" Makefile
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin"
+ mkdir -p "${D}/usr/share/man/man1"
+ einstall || die "einstall failed"
+}
diff --git a/app-crypt/md4sum/metadata.xml b/app-crypt/md4sum/metadata.xml
new file mode 100644
index 000000000000..28ef3c7b080f
--- /dev/null
+++ b/app-crypt/md4sum/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person"><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>