summaryrefslogtreecommitdiff
path: root/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/md4sum/md4sum-0.02.03-r1.ebuild')
-rw-r--r--app-crypt/md4sum/md4sum-0.02.03-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild b/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
new file mode 100644
index 000000000000..fac751884b0e
--- /dev/null
+++ b/app-crypt/md4sum/md4sum-0.02.03-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="md4 and edonkey hash algorithm tool"
+HOMEPAGE="http://linux.xulin.de/c/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/md4sum-fix-out-of-bounds-write.diff"
+}
+
+src_compile() {
+ sed -i -e "s:CFLAGS=:CFLAGS=${CFLAGS} :g" \
+ -e "s:install -s:install:g" Makefile
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin"
+ mkdir -p "${D}/usr/share/man/man1"
+ einstall || die "einstall failed"
+}