summaryrefslogtreecommitdiff
path: root/app-crypt/loop-aes-losetup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/loop-aes-losetup
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/loop-aes-losetup')
-rw-r--r--app-crypt/loop-aes-losetup/Manifest6
-rw-r--r--app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild79
-rw-r--r--app-crypt/loop-aes-losetup/metadata.xml11
3 files changed, 96 insertions, 0 deletions
diff --git a/app-crypt/loop-aes-losetup/Manifest b/app-crypt/loop-aes-losetup/Manifest
new file mode 100644
index 000000000000..0a3486d60237
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/Manifest
@@ -0,0 +1,6 @@
+DIST loop-AES-v3.7j.tar.bz2 326818 SHA256 67ede839d4cac657359c39b05eac46f6991054768a7e1096bef5b92edb3b8aba SHA512 e1b59680680e2b40bb42cad9f1e89a344c7bfd0ee01fdc26151e9edea64b5111744588bc05c672de16c76ae0a3e4d6a8d4c4c9c09709a9f93bfc62a2f64ba7c7 WHIRLPOOL a3798edc3f1393ddf97aeada84c1c5a6e74b8cef94e72629774c4db70001206d5cd429df61035a215131f0281ef284469751eefad1f7ee3fd7cf24153b57077d
+DIST util-linux-2.28.2.tar.xz 4149700 SHA256 b89d37146f20bede93a42c847bce881a17e6dbd8066ff2db2bee733fa409f0cd SHA512 ac1c2d4c92bbc4eabed464cb0334c1d9b21e58df0f07f0b26e7adcfa188879de8632d195b65a4358c5e11e14ac6e09a1c6206265bbf1fab4ce122414bee7e940 WHIRLPOOL 1735e33620dba30cc1f42e60b707adb72234006b7fea242ac98c389295617bd0225563bcffa76b9d0753dfa100775dd9a2b73614843645ce667db5536842e308
+EBUILD loop-aes-losetup-2.28.2.ebuild 2390 SHA256 fec37cbf5b10a0ba3173bfd293b21362d7683708072b518adea5ec774fa6740c SHA512 c71049614a40863c8634b142d16beb671f0cf77607b541018cfc44ab4bcfccf8b85e6f568e55963a30be8650d86c8fe6b0138914c7b0449592fe27062a6bcab3 WHIRLPOOL cb6c1d5cf8a8d0db3d4cc63278a7d3ff8d5cd7ea7eb869b735740092c706b3aed7231f66813dd968420705bc7b358912dc68566e83bca45f27389893aeb8857d
+MISC ChangeLog 3464 SHA256 2eace3ab41d744146f316c61ebee3496bfc7a89ec32d7940d0b59786a6cb8e59 SHA512 c0d0f4ce45927b76b515e9517e8cac18b69661a63650229bde42b38f7bff3733c2fc94f54929b4a997fc1bc8897b6bbaa43404c277451a39bc43aa7e47ec97bf WHIRLPOOL feca1a95fb9eccf93cb728273fc4c477b39709cf17ce509310c02bc728a024f6b3b7549d75265da7e02a8cc6c9d6fb84dff32641bc093ee0eb2b422eaed4d67b
+MISC ChangeLog-2015 712 SHA256 6f90106007eadd547894ff998ef2b1c3799cb3f90efccae8306d6c229aa160c3 SHA512 39277f20bc45bc85aa1756b5dd1e78d6a307b896989fa1ccb6f5958c0237fc4190acb3549e2fd9842486f74f056af518b42cf9e210eb163421c1eb20063ee116 WHIRLPOOL 5ed8049747d2055b75b0586a4c98427389d091c3a521f272897ee63e7f869d462928982d721c0f7ebb88e65100e192e2cd9f8925e2a7080d4363990dc29d967f
+MISC metadata.xml 318 SHA256 a980037629c41bfe0eae2f18978291a66d249c8b3072ebee3fa786c23cc4453c SHA512 93c67a250f19a2a17bde884a0f493b5b675ae2e0b4dd89164dc8a052e7adb9b2b5ebd07a43fb5432a8198216134ed3a0eca4b14bc98b9be71e9d947f51b77439 WHIRLPOOL c5253ad1c639309c61950071f2e0bf460b381e1288cf97c6b232375033eb627cf979faf562765452b51efc00b4b9e9fb43ce40067220ec571ab15da2fdca212b
diff --git a/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild
new file mode 100644
index 000000000000..abeaf0b775d7
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools toolchain-funcs libtool flag-o-matic
+
+MY_PV="${PV/_/-}"
+MY_P="util-linux-${MY_PV}"
+LOOPAES_P="loop-AES-v3.7j"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Loop-AES losetup utility"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
+SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
+SLOT="0"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+PATCHES=(
+ "${WORKDIR}/${LOOPAES_P}/util-linux-${PV}.diff"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+lfs_fallocate_test() {
+ # Make sure we can use fallocate with LFS #300307
+ cat <<-EOF > "${T}"/fallocate.${ABI}.c
+ #define _GNU_SOURCE
+ #include <fcntl.h>
+ main() { return fallocate(0, 0, 0, 0); }
+ EOF
+ append-lfs-flags
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
+ || export ac_cv_func_fallocate=no
+ rm -f "${T}"/fallocate.${ABI}.c
+}
+
+src_configure() {
+ lfs_fallocate_test
+ # The scanf test in a run-time test which fails while cross-compiling.
+ # Blindly assume a POSIX setup since we require libmount, and libmount
+ # itself fails when the scanf test fails. #531856
+ tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
+ # We manually set --libdir to the default since on prefix, econf will set it to
+ # a value which the configure script does not recognize. This makes it set the
+ # usrlib_execdir to a bad value. bug #518898#c2, fixed upstream for >2.25
+ ECONF_SOURCE=${S} \
+ econf \
+ --libdir='${prefix}/'"$(get_libdir)" \
+ --disable-all-programs \
+ --disable-pylibmount \
+ --enable-libsmartcols \
+ --enable-losetup \
+ --without-ncurses \
+ --without-udev \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use static && echo --enable-static-programs=losetup)
+}
+
+src_install() {
+ emake install DESTDIR="${T}/root"
+ newsbin "${T}/root/sbin/losetup" loop-aes-losetup
+ newman "${T}/root/usr/share/man/man8/losetup.8" loop-aes-losetup.8
+ use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
+}
diff --git a/app-crypt/loop-aes-losetup/metadata.xml b/app-crypt/loop-aes-losetup/metadata.xml
new file mode 100644
index 000000000000..12925882c9ff
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">loop-aes</remote-id>
+ </upstream>
+</pkgmetadata>