summaryrefslogtreecommitdiff
path: root/app-crypt/libnitrokey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-15 05:47:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-15 05:47:25 +0100
commit0bec4ab1937eed98ee24e2d48f0cfec46de2fc58 (patch)
treedf02387be31711c7c547c95c5e43d1066918a7a0 /app-crypt/libnitrokey
parent437bd70f28c6d5b2f34cba67ba2bb581025f56ea (diff)
gentoo auto-resync : 15:04:2023 - 05:47:25
Diffstat (limited to 'app-crypt/libnitrokey')
-rw-r--r--app-crypt/libnitrokey/Manifest4
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.8.ebuild55
-rw-r--r--app-crypt/libnitrokey/libnitrokey-9999.ebuild6
3 files changed, 61 insertions, 4 deletions
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
index 67010e6ec857..39cd02962fe3 100644
--- a/app-crypt/libnitrokey/Manifest
+++ b/app-crypt/libnitrokey/Manifest
@@ -1,4 +1,6 @@
DIST libnitrokey-3.6.tar.gz 98038 BLAKE2B 27f99e7b6de93548fc7a373f37ce784da0aa50503a5c635b4d90282e6330a5ff4c0dcc03a83a7e57045b8a1aabaab27d76a090d7c49693a6ff1037b81e75ece9 SHA512 a00a6724e5c64715eca688ec254efd979acceb5ff4cad28a205f7128e44db8674a5924634fd7da6c69d589deafca7b28b99e1d05a244c321d5cb429f2e5a3bec
+DIST libnitrokey-3.8.tar.gz 118197 BLAKE2B 6216229d718e6c1763abc56cc6cea341bcc7c6e1ea1a100a490d72786e5ce88d5784c1452036835a0a2fa104254d807d135efaee4b1696508c9c9d0d865e78a1 SHA512 30f966eed77aa75057b096d18f8e88d6be28a376dfc1888e44aff80347e031a16755d30acf1bca196acc5b922778d90627ac71cba22f5cb002ba3ec058939c90
EBUILD libnitrokey-3.6.ebuild 1110 BLAKE2B 8c675df63ba91e83e83314e079f9bc07042ac12584cc03f5c93bccc241ac97aa7ea1170e946559aa3a4426576bab7054d716530e71f12ef3839b8eadb714cb67 SHA512 f46adf94137b7b5f976fc566f48e46ccc97b791ec0dc03a6b8459f52c9f0bada878a8827a27d65c2e3240775f413ef6060a894c0ca89de078f5c26dcb305cf0b
-EBUILD libnitrokey-9999.ebuild 1112 BLAKE2B c2fb52f3577eb5f6343d16c4564e9a7228d9775c996770b3d52e49a65eb070a0075b67f64c74fa6ff761bff3e5c700c4a9aed19f6bf0bb1d21d8f089093a3d82 SHA512 0debea09cefd3df62598efed53028bc987bfe3eed730d1407c8ed1f3117f4654a26e0158e8b5e95214e44d1f39e219308896bdcfda1b289efd100b0a6705ab9a
+EBUILD libnitrokey-3.8.ebuild 1107 BLAKE2B 95f9d04299659e263f7aa811ea7fcb522dbe500c4f97ae8ad4ad8ed310d408758e869f6540a137f10ac3697f0cf4b6072ce38c475786c737681a5e0c17e7f3c6 SHA512 9e256b48a8e6497eb4dfd1da36ff99bc7b7267b4d1cd110f29b67f06b91af88aaad61865bead92eea688cf9bff79c6a33f4cd403b51ae5e70c1818976c10b677
+EBUILD libnitrokey-9999.ebuild 1107 BLAKE2B 95f9d04299659e263f7aa811ea7fcb522dbe500c4f97ae8ad4ad8ed310d408758e869f6540a137f10ac3697f0cf4b6072ce38c475786c737681a5e0c17e7f3c6 SHA512 9e256b48a8e6497eb4dfd1da36ff99bc7b7267b4d1cd110f29b67f06b91af88aaad61865bead92eea688cf9bff79c6a33f4cd403b51ae5e70c1818976c10b677
MISC metadata.xml 398 BLAKE2B fd2f4c092ed478b034cadf189ce032a24ae41bbc908b620c98125ad340a69b79ec4c1b39a3eaae065db746e16ba5e891eb9b5f6a31967fab8261bf7fd8f5b16e SHA512 657c44fed3145300a480a6b3c4765932414d1fe0f5cc1130ffbe358502b37b46effc7f8cbef4a12b751f8f19c22d64c52a1921b7ae4d19c920e08de67f39fa2d
diff --git a/app-crypt/libnitrokey/libnitrokey-3.8.ebuild b/app-crypt/libnitrokey/libnitrokey-3.8.ebuild
new file mode 100644
index 000000000000..b37e5cdbd34f
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-3.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev cmake
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ test? ( <dev-cpp/catch-3:0 )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/libnitrokey/libnitrokey-9999.ebuild b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
index a9135e08d5d4..b37e5cdbd34f 100644
--- a/app-crypt/libnitrokey/libnitrokey-9999.ebuild
+++ b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit udev cmake
@@ -29,7 +29,7 @@ RDEPEND="
virtual/udev"
DEPEND="
${RDEPEND}
- test? ( >=dev-cpp/catch-2.5.0:0 )"
+ test? ( <dev-cpp/catch-3:0 )"
BDEPEND="virtual/pkgconfig"
src_configure() {