summaryrefslogtreecommitdiff
path: root/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild')
-rw-r--r--app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild b/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
new file mode 100644
index 000000000000..3661c4b1d3f3
--- /dev/null
+++ b/app-crypt/kencfs-plasma/kencfs-plasma-1.6.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-plasma/}"
+inherit qmake-utils
+
+DESCRIPTION="GUI frontend for encfs"
+HOMEPAGE="https://www.linux-apps.com/content/show.php?content=134003"
+SRC_URI="https://dl.opendesktop.org/api/files/download/id/1486311191/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ kde-frameworks/kdelibs:4
+"
+RDEPEND="${DEPEND}
+ kde-frameworks/kwallet:5
+ sys-fs/encfs
+"
+
+PATCHES=(
+ "${FILESDIR}/${MY_PN}-1.4.0-encfs5.patch"
+ "${FILESDIR}/${MY_PN}-1.6.2-desktop.patch"
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ default
+
+ sed -i ${MY_PN}.pro -e "/^doc.path =/s/${MY_PN}/${MY_PN}-${PVR}/" \
+ || die "sed docdir failed"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}