summaryrefslogtreecommitdiff
path: root/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 02:06:21 +0000
commitf9fff8823e0cd1f6570b01337ac99e5bd49c824a (patch)
tree2a69b85ea6ba19c3a6b492d49ee8cd14c887472d /app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
parentd117172e3b48fc4be82b7623ffc40bb6070ef361 (diff)
gentoo auto-resync : 26:12:2022 - 02:06:21
Diffstat (limited to 'app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild')
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
new file mode 100644
index 000000000000..1d082547ec2f
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="https://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-do-not-strip-and-compress.patch
+)
+
+src_configure() {
+ filter-flags '*'
+ append-cflags '-O0'
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+ newinitd "${FILESDIR}"/jitterentropy-rngd-initd jitterentropy-rngd
+}