summaryrefslogtreecommitdiff
path: root/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild')
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild33
1 files changed, 22 insertions, 11 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
index a7366acbcaa0..6252285e3f18 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
@@ -1,21 +1,32 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="git://git.code.sf.net/p/linux-ima/ima-evm-utils"
-EGIT_BOOTSTRAP="autogen.sh"
-
-inherit git-2 eutils
+inherit autotools git-r3
DESCRIPTION="Supporting tools for IMA and EVM"
HOMEPAGE="http://linux-ima.sourceforge.net"
-SRC_URI=""
+EGIT_REPO_URI="git://git.code.sf.net/p/linux-ima/ima-evm-utils"
-DEPEND="sys-apps/keyutils"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-apps/keyutils"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="debug"
+
+src_prepare() {
+ default
+
+ sed -i '/^MANPAGE_DOCBOOK_XSL/s:/usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl:/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}