summaryrefslogtreecommitdiff
path: root/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
commite3cf2c86fca1750343c1885311f857f185ee4f2d (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
parentf1af93971b7490792d8541bc790e0d8c6d787059 (diff)
gentoo resync : 08.09.2019
Diffstat (limited to 'app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild')
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
new file mode 100644
index 000000000000..93152d948962
--- /dev/null
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Supporting tools for IMA and EVM"
+HOMEPAGE="http://linux-ima.sourceforge.net"
+SRC_URI="mirror://sourceforge/linux-ima/${P}.tar.gz"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-apps/keyutils:="
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-configure-use-sys-xattr-bug-649790.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i '/^MANPAGE_DOCBOOK_XSL/s:/usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl:/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}