summaryrefslogtreecommitdiff
path: root/app-crypt/hmaccalc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/hmaccalc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/hmaccalc')
-rw-r--r--app-crypt/hmaccalc/Manifest3
-rw-r--r--app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild24
-rw-r--r--app-crypt/hmaccalc/metadata.xml17
3 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/hmaccalc/Manifest b/app-crypt/hmaccalc/Manifest
new file mode 100644
index 000000000000..ab5e901a0f59
--- /dev/null
+++ b/app-crypt/hmaccalc/Manifest
@@ -0,0 +1,3 @@
+DIST hmaccalc-0.9.14.tar.gz 111893 BLAKE2B 30aebd67e49db354c616110477e78fd6923df3ddfbe5e5023fd791bd90c783031da8c631fbfc9e5f2bdae06a08da1d56a08df921ddee359b630c5665e833ad4e SHA512 688a72b4e534ca4a1d45a116c0361ffd389de93dfdeec68e35cbffe0be13832789abaf33300003e12c7317ba473d3a0415f4b22cb3b7b36946c04bd40aa49184
+EBUILD hmaccalc-0.9.14.ebuild 570 BLAKE2B ba3b4eae888ea54a913ecf6032b28963b2ac52f26d61686a082f3bf224c5ec2e3802c799d06d1701027b3ae9d392f0b116a7d75e4e82659c1790566f1466854d SHA512 b0a6335a64fde93f59be97e62de212333dd8c446eb9b564117b9fcabf5d5d5a4ee629b6dcd83b58dd57411119b50c3ee2c068a4c782d3388f5b00078aa67698b
+MISC metadata.xml 671 BLAKE2B 276b40259996c8556788b1aecc645cd2e344908e8705d4b73771401a07eb1a75132d81589ef046ad7e1b72d4421251a9690e10668d43a67a0cb925be58835e77 SHA512 d4bb7d03ed78f667255e38138262ccdfe33c42707e967817c52d8f445552b9502d6ed1a10a96df7e20cc62f7fa06c2285057a2f81cff1004b28c6e0c20fb17b7
diff --git a/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild b/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild
new file mode 100644
index 000000000000..08448ab7923e
--- /dev/null
+++ b/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="Tools for computing and checking HMAC values for files"
+HOMEPAGE="https://pagure.io/hmaccalc"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fips"
+
+DEPEND="dev-libs/nss
+ sys-devel/prelink"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-sum-directory=/usr/$(get_libdir)/${PN}/ \
+ $(use_enable !fips non-fips)
+}
diff --git a/app-crypt/hmaccalc/metadata.xml b/app-crypt/hmaccalc/metadata.xml
new file mode 100644
index 000000000000..6557d925ad15
--- /dev/null
+++ b/app-crypt/hmaccalc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>crypto@gentoo.org</email>
+<name>Crypto</name>
+</maintainer>
+<use>
+<flag name="fips">Enable NSS FIPS mode and support only the FIPS-compliant functions</flag>
+</use>
+<longdescription>
+hmaccalc can be used to compute HMAC (hash-based message authentication code)
+values for files. An HMAC is similar in concept to a message digest, except in
+that its calculation also incorporates a key which must be known to both the
+party generating the HMAC and the party verifying the HMAC.
+</longdescription>
+</pkgmetadata>