summaryrefslogtreecommitdiff
path: root/app-crypt/heimdal/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/heimdal/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/heimdal/files')
-rw-r--r--app-crypt/heimdal/files/heimdal-kadmind.confd5
-rw-r--r--app-crypt/heimdal/files/heimdal-kadmind.initd-r222
-rw-r--r--app-crypt/heimdal/files/heimdal-kcm.confd5
-rw-r--r--app-crypt/heimdal/files/heimdal-kcm.initd-r121
-rw-r--r--app-crypt/heimdal/files/heimdal-kdc.confd5
-rw-r--r--app-crypt/heimdal/files/heimdal-kdc.initd-r224
-rw-r--r--app-crypt/heimdal/files/heimdal-kpasswdd.confd5
-rw-r--r--app-crypt/heimdal/files/heimdal-kpasswdd.initd-r222
-rw-r--r--app-crypt/heimdal/files/heimdal_disable-check-iprop.patch16
-rw-r--r--app-crypt/heimdal/files/heimdal_tinfo.patch22
-rw-r--r--app-crypt/heimdal/files/krb5.conf27
11 files changed, 174 insertions, 0 deletions
diff --git a/app-crypt/heimdal/files/heimdal-kadmind.confd b/app-crypt/heimdal/files/heimdal-kadmind.confd
new file mode 100644
index 000000000000..5d75504a1402
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kadmind.confd
@@ -0,0 +1,5 @@
+# /etc/conf.d/heimdal-kadmind
+
+# Options to pass to the kadmind daemon. Please see man 8 kadmind for details.
+#
+# OPTIONS="--keytab=/etc/krb5.keytab"
diff --git a/app-crypt/heimdal/files/heimdal-kadmind.initd-r2 b/app-crypt/heimdal/files/heimdal-kadmind.initd-r2
new file mode 100644
index 000000000000..694e6d1d9ad2
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kadmind.initd-r2
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net heimdal-kdc
+ after logger
+}
+
+start() {
+ ebegin "Starting Heimdal kadmind"
+ /usr/sbin/kadmind "${OPTIONS}" &
+ echo $! > /var/run/heimdal-kadmind.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kadmind"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kadmind
+ eend $?
+}
diff --git a/app-crypt/heimdal/files/heimdal-kcm.confd b/app-crypt/heimdal/files/heimdal-kcm.confd
new file mode 100644
index 000000000000..8c156aa9b677
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kcm.confd
@@ -0,0 +1,5 @@
+# /etc/conf.d/heimdal-kcm
+
+# Options to pass to the kcm daemon. Please see man 8 kcm for details
+#
+# OPTIONS="-c /etc/krb5.conf"
diff --git a/app-crypt/heimdal/files/heimdal-kcm.initd-r1 b/app-crypt/heimdal/files/heimdal-kcm.initd-r1
new file mode 100644
index 000000000000..88824dd7e34f
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kcm.initd-r1
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ after heimdal-kdc
+}
+
+OPTIONS="${OPTIONS} --detach"
+
+start() {
+ ebegin "Starting Heimdal KCM..."
+ start-stop-daemon --start --pidfile /var/run/kcm.pid --exec /usr/sbin/kcm -- ${OPTIONS# }
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal KCM..."
+ start-stop-daemon --stop --pidfile /var/run/kcm.pid --retry SIGKILL/5
+ eend $?
+}
diff --git a/app-crypt/heimdal/files/heimdal-kdc.confd b/app-crypt/heimdal/files/heimdal-kdc.confd
new file mode 100644
index 000000000000..d33f663feccd
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kdc.confd
@@ -0,0 +1,5 @@
+# /etc/conf.d/heimdal-kdc
+
+# Options to pass to the kdc daemon. Please see man 8 kdc for details
+#
+# OPTIONS="-c /etc/krb5.conf"
diff --git a/app-crypt/heimdal/files/heimdal-kdc.initd-r2 b/app-crypt/heimdal/files/heimdal-kdc.initd-r2
new file mode 100644
index 000000000000..8d3f4f4b60c6
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kdc.initd-r2
@@ -0,0 +1,24 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net
+ after logger
+}
+
+OPTIONS="${OPTIONS} --detach"
+
+start() {
+ ebegin "Starting Heimdal kdc"
+ start-stop-daemon --start --quiet --exec \
+ /usr/sbin/kdc -- ${OPTIONS# }
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kdc"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kdc
+ eend $?
+}
diff --git a/app-crypt/heimdal/files/heimdal-kpasswdd.confd b/app-crypt/heimdal/files/heimdal-kpasswdd.confd
new file mode 100644
index 000000000000..7a3e808a9715
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kpasswdd.confd
@@ -0,0 +1,5 @@
+# /etc/conf.d/heimdal-kpasswdd
+
+# Options to pass to the kpasswdd daemon. Please see man 8 kpasswdd for details.
+#
+# OPTIONS="-k /etc/krb5.keytab"
diff --git a/app-crypt/heimdal/files/heimdal-kpasswdd.initd-r2 b/app-crypt/heimdal/files/heimdal-kpasswdd.initd-r2
new file mode 100644
index 000000000000..a614c2232d85
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal-kpasswdd.initd-r2
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use net heimdal-kdc
+ after logger
+}
+
+start() {
+ ebegin "Starting Heimdal kpasswdd"
+ start-stop-daemon --background --start --quiet --exec \
+ /usr/sbin/kpasswdd -- "${OPTIONS}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Heimdal kpasswdd"
+ start-stop-daemon --stop --quiet --exec \
+ /usr/sbin/kpasswdd
+ eend $?
+}
diff --git a/app-crypt/heimdal/files/heimdal_disable-check-iprop.patch b/app-crypt/heimdal/files/heimdal_disable-check-iprop.patch
new file mode 100644
index 000000000000..703fc7c94d46
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_disable-check-iprop.patch
@@ -0,0 +1,16 @@
+diff --git a/tests/kdc/check-iprop.in b/tests/kdc/check-iprop.in
+index ba9aff1..0bea2ed 100644
+--- a/tests/kdc/check-iprop.in
++++ b/tests/kdc/check-iprop.in
+@@ -31,6 +31,11 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+
++# check-iprop is known to fail and there is no easy way out
++# http://article.gmane.org/gmane.comp.encryption.kerberos.heimdal.general/5408
++# http://article.gmane.org/gmane.comp.encryption.kerberos.heimdal.general/5409
++exit 77
++
+ top_builddir="@top_builddir@"
+ env_setup="@env_setup@"
+ objdir="@objdir@"
diff --git a/app-crypt/heimdal/files/heimdal_tinfo.patch b/app-crypt/heimdal/files/heimdal_tinfo.patch
new file mode 100644
index 000000000000..010a9037c7e6
--- /dev/null
+++ b/app-crypt/heimdal/files/heimdal_tinfo.patch
@@ -0,0 +1,22 @@
+--- heimdal-1.5/configure.ac.orig 2011-08-01 12:49:33.554689000 +0200
++++ heimdal-1.5/configure.ac 2011-08-01 13:54:12.707009421 +0200
+@@ -444,7 +444,7 @@
+ #endif
+ ],[0,0,0,0,0])
+
+-AC_FIND_FUNC_NO_LIBS(tgetent, termcap ncurses curses,[
++AC_FIND_FUNC_NO_LIBS(tgetent, tinfo ncurses curses termcap,[
+ #ifdef HAVE_TERMCAP_H
+ #include <termcap.h>
+ #endif
+--- heimdal-1.5/lib/libedit/configure.ac~ 2011-07-30 22:43:29.000000000 +0200
++++ heimdal-1.5/lib/libedit/configure.ac 2011-08-01 13:54:30.657009419 +0200
+@@ -33,7 +33,7 @@
+ EL_MANTYPE
+
+
+-AC_CHECK_LIB(curses, tgetent,,
++AC_CHECK_LIB(tinfo, tgetent,,
+ [AC_CHECK_LIB(ncurses, tgetent,,
+ [AC_MSG_ERROR([libcurses or libncurses are required!])] )] )
+
diff --git a/app-crypt/heimdal/files/krb5.conf b/app-crypt/heimdal/files/krb5.conf
new file mode 100644
index 000000000000..906eb4d087d0
--- /dev/null
+++ b/app-crypt/heimdal/files/krb5.conf
@@ -0,0 +1,27 @@
+[libdefaults]
+ default_realm = MY.REALM
+# clockskew = 300
+# v4_instance_resolve = false
+# v4_name_convert = {
+# host = {
+# rcmd = host
+# ftp = ftp
+# }
+# plain = {
+# something = something-else
+# }
+# }
+
+[realms]
+ MY.REALM = {
+ kdc = MY.COMPUTER
+ }
+# OTHER.REALM = {
+# v4_instance_convert = {
+# kerberos = kerberos
+# computer = computer.some.other.domain
+# }
+# }
+
+[domain_realm]
+ .my.domain = MY.REALM