summaryrefslogtreecommitdiff
path: root/app-crypt/hashcat/hashcat-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /app-crypt/hashcat/hashcat-9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'app-crypt/hashcat/hashcat-9999.ebuild')
-rw-r--r--app-crypt/hashcat/hashcat-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-crypt/hashcat/hashcat-9999.ebuild b/app-crypt/hashcat/hashcat-9999.ebuild
index d85c65f96f6b..32005fae3ae5 100644
--- a/app-crypt/hashcat/hashcat-9999.ebuild
+++ b/app-crypt/hashcat/hashcat-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit eutils pax-utils multilib
@@ -12,17 +12,20 @@ SLOT="0"
if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/hashcat/hashcat.git"
- KEYWORDS=""
else
KEYWORDS="~amd64"
SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
IUSE="brain video_cards_nvidia"
-DEPEND="virtual/opencl
+DEPEND="
app-arch/lzma
brain? ( dev-libs/xxhash )
- video_cards_nvidia? ( >x11-drivers/nvidia-drivers-367.0 )"
+ video_cards_nvidia? ( >x11-drivers/nvidia-drivers-440.64
+ || ( dev-util/nvidia-cuda-toolkit
+ virtual/opencl )
+ )
+ !video_cards_nvidia? ( virtual/opencl )"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -39,7 +42,7 @@ src_prepare() {
export PREFIX=/usr
export LIBRARY_FOLDER="/usr/$(get_libdir)"
export DOCUMENT_FOLDER="/usr/share/doc/${P}"
- eapply_user
+ default
}
src_compile() {